i386/113895: xl0 fails on 6.2-RELEASE but worked fine on 5.5-RELEASE

Ernest Hua ehua at maxiscale.com
Thu Jun 21 03:50:01 UTC 2007

>Number:         113895
>Category:       i386
>Synopsis:       xl0 fails on 6.2-RELEASE but worked fine on 5.5-RELEASE
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-i386
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Jun 21 03:50:00 GMT 2007
>Originator:     Ernest Hua
>Release:        6.2-RELEASE
FreeBSD ehuabsd.maxiscale.local 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007     root at dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP  i386
cpu         = Athlon 64 X2 4600+ (2.4GHz)
motherboard = Asus M2N-MX
memory      = 2x2 1GB DDR800 (4GB total)
ethernet    = 3Com 3C905B

This hardware configuration worked just fine with 5.5-RELEASE, but 6.2-RELEASE cannot seem to keep the link up enough to pass much traffic.  xl0 keeps saying that there is a watchdog timeout.

This "watchdog timeout" symptom seems to be popular, but I've tried changing NIC cards, changing motherboards (another instance of the same type), changing PCI slots, changing BIOS PnP setting, etc ...

None of these remedies work.  But 5.5-RELEASE sure does!

By the way, an AirLink101 Gb Ethernet card also does not work in 6.2-RELEASE but also works like a charm in 5.5-RELEASE.  It sure does seem like something is very fishy in 6.2-RELEASE.

Use the same hardware configuration.
Just boot it up on 6.2-RELEASE.



More information about the freebsd-i386 mailing list