i386/96030: Install hangs with Broadcomm 440x NIC installed

Jianqin Qu jqu at its.brooklyn.cuny.edu
Thu May 11 14:40:32 UTC 2006


The following reply was made to PR i386/96030; it has been noted by GNATS.

From: Jianqin Qu <jqu at its.brooklyn.cuny.edu>
To: Stephen <stephen at randomcruft.com>
Cc: freebsd-gnats-submit at freebsd.org, freebsd-i386 at freebsd.org
Subject: Re: i386/96030: Install hangs with Broadcomm 440x NIC installed
Date: Thu, 11 May 2006 09:59:19 -0400 (EDT)

   This message is in MIME format.  The first part should be readable text,
   while the remaining parts are likely unreadable without MIME-aware tools.
 
 ---559023410-851401618-1147099723=:11332
 Content-Type: TEXT/PLAIN; CHARSET=US-ASCII; format=flowed
 Content-ID: <Pine.SOC.4.64.0605110954211.14077 at atrium67.its.brooklyn.cuny.edu>
 
 Please try the attached patch. The patch is against FreeBSD-6.0-RELEASE.
 Actually only one line of code is added. It seems the bug comes from
 an incomplete fix to a previous bug.
 
 Jianqin
 
 On Wed, 19 Apr 2006, Stephen wrote:
 
 >
 >> Number:         96030
 >> Category:       i386
 >> Synopsis:       Install hangs with Broadcomm 440x NIC installed
 >> Confidential:   no
 >> Severity:       serious
 >> Priority:       medium
 >> Responsible:    freebsd-i386
 >> State:          open
 >> Quarter:
 >> Keywords:
 >> Date-Required:
 >> Class:          sw-bug
 >> Submitter-Id:   current-users
 >> Arrival-Date:   Wed Apr 19 01:50:15 GMT 2006
 >> Closed-Date:
 >> Last-Modified:
 >> Originator:     Stephen
 >> Release:        Happens with 6.0-RELEASE and 6.1-RC1
 >> Organization:
 > N/A
 >> Environment:
 > Can't provide as I can't get through a full installation.
 >> Description:
 > During the installation of 6.0-RELEASE and 6.1-RC1 the installation hangs when it gets to the point of trying to dsetup and ethernet adapter.
 >
 > I am running a Dell Inspiron 9300, with a Broadcom 440x internal NIC. The bfe driver appears to initialize the card properly during hardware discovery as I have a link light.  Once I get to the point in the installation where it asks if I would like to setup an ethernet adapater, if I select yes and choose to attempt IPv6 it (the system) no longer responds.  There is also no link light at this point.  I've also tried this path and tried to skip IPv6 and go to DHCP, same result.
 >
 > It appears that ifconfig is trying to down the interface (which doesn't make sense since it was already "up") and then bring it back up but it get's "stuck".
 >
 > If I ignore setting up the ethernet adapter the install will finish properly.  But, if I try to run dhclient by hand the same thing will happen (machine hangs, have to hard boot).
 >
 > I'm sure you folks are aware of it already since it looks like an ongoing problem, but though I would confirm that the issue is ther in 6.1-RC1
 >> How-To-Repeat:
 > Start installation on a system w/ a Broadcom 440x NIC. Attempt to configure NIC using the installer, system will hang / lockup.  Or, run installer and not configure NIC, upon reboot and logging into the system run dhclient by hand, system will hang.
 >> Fix:
 > Not sure what the actual issue is, i'm not able to provide a fix (unfortunatley)
 >> Release-Note:
 >> Audit-Trail:
 >> Unformatted:
 > _______________________________________________
 > freebsd-i386 at freebsd.org mailing list
 > http://lists.freebsd.org/mailman/listinfo/freebsd-i386
 > To unsubscribe, send any mail to "freebsd-i386-unsubscribe at freebsd.org"
 >
 ---559023410-851401618-1147099723=:11332
 Content-Type: TEXT/PLAIN; CHARSET=US-ASCII; NAME=if_bfe.patch
 Content-Transfer-Encoding: BASE64
 Content-ID: <Pine.SOC.4.64.0605081048430.11332 at atrium67.its.brooklyn.cuny.edu>
 Content-Description: 
 Content-Disposition: ATTACHMENT; FILENAME=if_bfe.patch
 
 LS0tIHN5cy9kZXYvYmZlL2lmX2JmZS5jLm9yZwlTdW4gT2N0ICA5IDEyOjE1
 OjExIDIwMDUNCisrKyBzeXMvZGV2L2JmZS9pZl9iZmUuYwlNb24gTWF5ICA4
 IDIyOjM5OjM3IDIwMDYNCkBAIC03MTksNiArNzE5LDkgQEANCiAJCQkgICAg
 MTAwLCAwKTsNCiAJCUNTUl9XUklURV80KHNjLCBCRkVfRE1BUlhfQ1RSTCwg
 MCk7DQogCQlzYy0+YmZlX3J4X3Byb2QgPSBzYy0+YmZlX3J4X2NvbnMgPSAw
 Ow0KKw0KKwkJLyogU29mdHdhcmUgUmVzZXQgKi8NCisJCUJGRV9PUihzYywg
 QkZFX0VORVRfQ1RSTCwgQkZFX0VORVRfU1JTVCk7DQogCX0NCiANCiAJYmZl
 X2NvcmVfcmVzZXQoc2MpOw0K
 
 ---559023410-851401618-1147099723=:11332--


More information about the freebsd-i386 mailing list