Frebsd 7-STABLE, atapicd, atapicam and Intel errors [SOLVED]

Jeremy Chadwick koitsu at FreeBSD.org
Wed Nov 19 03:21:04 PST 2008


On Wed, Nov 19, 2008 at 11:55:34AM +0100, Jan Sebosik wrote:
> Allright, I`ve played again with an HPET in BIOS little bit.
>
> Results ->
>
> HPET disabled:
>
>   kern.timecounter.choice: TSC(-100) ACPI-fast(1000) i8254(0)  
> dummy(-1000000)
>   kern.timecounter.hardware: ACPI-fast
>
> HPET enabled:
>
>   kern.timecounter.choice: TSC(-100) HPET(900) ACPI-fast(1000) i8254(0)  
> dummy(-1000000)
>   kern.timecounter.hardware: ACPI-fast
>
>
> But now FreeBSD boots also with HPET enabled (really don`t understand  
> what`s going on).
>
> When I was trying to mount cd with "mount -t cd9660 /dev/cd0 /mnt/cd0",  
> mount works as expected (atapicd module not loaded).
>
> Then I`ve kldload-ed atapicd, "mouunt -t cd9660 /dev/acd0 /mnt/cd0"  
> (acd0, not cd0), but this ended with messages like this:
> unknown: FAILURE - READ_BIG timeout (retry count 0)
>
> Temporary I`ve disabled HPET in BIOS (Linux got problems too-> he  
> created gigabytes of log messages in /var/log/messages :D).
>
> Best regards, Jan
>
> Jeremy Chadwick napsal(a):
>> On Wed, Nov 19, 2008 at 11:19:37AM +0100, Jan Sebosik wrote:
>>> Hi
>>>
>>> Yeah, I`ve tested it 2 times (switching it in BIOS). To me it seems 
>>> bit  mysterious, why there is a relationship between HPET setting and 
>>> acd/cd  problems in FreeBSD.
>>>
>>>
>>> Jeremy Chadwick napsal(a):
>>>> On Wed, Nov 19, 2008 at 11:08:34AM +0100, Jan Sebosik wrote:
>>>>> Hi again
>>>>>
>>>>> so it seems to be a problem with HPET timer which is onboard and 
>>>>> was  enabled. If I turned him off, (acd | cd) problems went away.
>>>>>
>>>>>
>>>>> Jan Sebosik napsal(a):
>>>>>> Hi all
>>>>>>
>>>>>> OS: Freebsd 7-STABLE from CVS of today
>>>>>> Problematic HW: Intel DQ45CB  (Q45 chipset, ICH10, SATA in 
>>>>>> native mode, but not AHCI), LG SATA DVD-RW GH20NS15
>>>>>>
>>>>>> Problem: if I run freebsd without LG DVD connected to any SATA 
>>>>>> port  onboard everything works allright. When I connect SATA 
>>>>>> DVD to board,  then freebsd refuses to boot with messages 
>>>>>> similar to those:
>>>>>>
>>>>>> acd0: FAILURE-READ_BIG timed out
>>>>>> unknown: FAILURE-READ_BIG timed out
>>>>>> cddone: goit error 0x5 back
>>>>>>
>>>>>> Messages are repeating forever.
>>>>>>
>>>>>> Anybody knows where should be a bug?
>>>>>> Temporary I`ve disconnected LG SATA burner from system board.
>>>>>>
>>>>>> Thanks for any idea.
>>>>>>
>>>>>> Best regards
>>>> Are you ***absolutely 100% certain*** this is true?  The time counter
>>>> selected shouldn't have anything to do with the errors you see.
>>>> Please thoroughly test this.
>>>>
>>>> I'd CC jhb@ to get confirmation of my statement, but I've promised
>>>> myself I wouldn't bother him until 2009.  :-)
>>
>> This is very bizarre.  The errors being returned from acd0 are that an
>> ATAPI/ATA command (READ_BIG, whatever the code for that is) did not
>> receive a response from the controller or device within 5 seconds
>> (assuming the ata(4) timeout values here; it could be something larger
>> for ATAPI, I don't know).  Maybe some a BIOS bug...
>>
>> Can you show us output from the following two commands?
>>
>> sysctl kern.timecounter.choice
>> sysctl kern.timecounter.hardware
>>
>> Soren, do you know how/if the HPET time counter could cause this oddity?
>> All of my systems use ACPI-fast, so I can't test this.

What this proves is that disabling HPET in the BIOS makes absolutely no
change to FreeBSD as far as the timecounter goes.  It's still using
ACPI-fast no matter if HPET is disabled or not.  Disabling HPET does
show up in FreeBSD (as you can tell), but the ATA/ATAPI stuff *should
not* have some direct tie-in to HPET.

I'm left believing you've found a BIOS bug.  Please bring this up with
your motherboard or system vendor.

-- 
| Jeremy Chadwick                                jdc at parodius.com |
| Parodius Networking                       http://www.parodius.com/ |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |



More information about the freebsd-hardware mailing list