cdrom: reading problem

Claude Baudouin cbaud at
Wed May 30 02:09:22 UTC 2007


I installed FreeBSD6.1 on  old PC :

2xchannel IDE controller ATA mode 4 compatible
3xPCI v2.0
3xISA 16bit
2 disks, 600Mo et 2Go  connected at primary IDE
1 x cdrom connected at secondary IDE
FreeBSD 6.1 kernel noyau  generic

I installed with floppy and ftp because the cdrom drive don't work right.
I have tried two CDROM drive :
"HITACHI model CDR-7730" and "SAMSUNG SCR-243", but I have the same 
problem I get the next error messages after mounting:

#mount_cd9660 /dev/acd0 /cdrom
acd0 : TIMEOUT-READ_BIG retrying (1 retry left)
acd0 : TIMEOUT-READ_BIG retrying ((0 retries left)
acd0: FAILURE-READ timed out
g_vfs_done(): acd0[READ(offset=34816, length=2048)] error=5
mount_cd9660: /dec/acd0: input/output error

I have tried several CD disks and also " kldload atapicam" and 
"hw.ata.atapi_dma=0 et 1 but I get the same kind of message:
"g_vsf_done(): acd0[READ(offset ...etc"
The error messages happend especially if one want to copy a big file 
from the cdrom drive to a harddisk.
 With "sysinstall" I had always error messages.
Anyone an idea?


More information about the freebsd-hardware mailing list