Problems w/Intel D946GZIS + Pentium D (Possible SMP Problem)

Tim Daneliuk tundra at
Sun May 27 19:28:25 UTC 2007

Just bought:

Intel D946GZIS MOBO w/ICH7 SATA-II support
WDC WD2500JS-00NCB1 250G Hard Drive that claims to do 3G/s
Pentium D @ 3.2GHz

In addition to the on-board peripherals, the two available
PCI slots have an Adaptec 2930CU SCSI controller and
a 3Com 3C901 card in them respectively.

I've run into a problem that makes no sense to me and I suspect
is related to how SMP works (or, then again, maybe not):

1) When booting FBSD 6.2, right after the second CPU is started
    the system hangs for about 45 seconds and then proceeds normally.
    This happens with GENERIC-Release, SMP-Stable, and SMP-Release kernels.

Other strange anomalies I've noted:

2) If I try to boot the 4.11-Release CD, it gets partway through
    the boot and then spits out:

     RTC BIOS diagnostic error 80<clock battery>

   I've replaced the RTC battery and still get the same error.
   I get no such error with 6.2

3) Both the MOBO and drive are SATA-300 rated, but 6.2 insists that
    the drive is running at SATA-150.  I have verified that the drive
    has no jumper forcing it into this mode.

Anyone have ideas on what is going on here?  (I've DAGS and found nothing
like this in the archives.)
Tim Daneliuk     tundra at
PGP Key:

More information about the freebsd-hardware mailing list