Tyan S2881, Broadcom (bge) NIC corrupting downloads

Jasen Gibson jasen at hondavision.com
Sat Sep 16 12:54:26 PDT 2006

>From all I've been told by folks on the amd64 mailing lists, this board is
fully supported by FreeBSD 6.1, which is why I chose this model.  And, in
fact, the OS installs fine and correctly detects and installs the drivers
for the hardware.


My problem, in a nutshell, is that large downloads become corrupted in
transit.  Anything over a couple MB will have a CRC error somewhere in the
file, 99% of the time.

So using the ports tree to install large ports always fails with checksum
failures.  (So, most of them)

At first I though maybe it was just a bug between this version of FreeBSD
and the bge (Broadcom) driver.

My hardware setup:

Tyan S2881, K8SR

2 Opteron 248's

2 1GB Corsair ECC DDR

1 WD Raptor 74GB, on built-in (silicon image) SATA controller

Adaptec 2420A PCI-X SATA RAID card containing

   4 WD RE400's in a RAID 5 array (not even being used yet)


The RAID is unused, it's just sitting there.  The Raptor is the main OS
drive, and is where I've been attempting to save the files.


What I've done so far to troubleshoot this:

1.	Tried both LAN ports.  Both have the same issue. 
2.	Removed each processor, one at a time, to eliminate them as a cause.

3.	Tried each stick of RAM, one at a time, to eliminate these as a
4.	Ran Memtest86+ from bootable CD.  No errors found. 
5.	Clean installed both the amd64 and i386 platforms of FreeBSD.  Both
have same issue. 
6.	Tried with the Adaptec card installed and not installed.  Seemed to
make no difference. 
7.	Newest BIOS revision update has been applied. 


To make this even more interesting, files are only corrupted when
transferred on port 80!  I can transfer large files over FTP or Samba just
fine, but when transferred over http or fetch they come down with problems.

For instance, downloading a port on my Windows box and then transferring it
to the distfiles folder via FTP will allow the port to extract, compile and
install just fine.  Downloading that same file via fetch from this box
itself will result in a crc or checksum error.

Other computers on this same LAN have no download problems, so there is no
network/infrastructure issue.

I feel I have sufficiently excluded both RAM and processors as the cause, as
the odds of either both processors or both sticks of RAM having this same
unique defect seems rather slim, and the behavior does not stop when the
Adaptec card is removed.


What more can I do before just RMA'ing this motherboard?  I can't even
really confirm it's a hardware failure at this point.


More information about the freebsd-hardware mailing list