broken USB in 5.5-stable

Rick C. Petty rick-freebsd at
Fri Dec 22 00:08:59 PST 2006


I freshly upgraded a 5.1+ i386 box to the latest 5.5-stable.  For some
reason, I can't get it to recognize any USB devices (I've only tried
mice, a scanner, and a printer).  I know usbd is running:

# ps axww | grep usbd
  414  ??  Ss     0:00:00 /usr/sbin/usbd

At first I thought maybe my mouse was broken, so I booted to my old 5.1
drive, works like a charm.  Maybe USB wasn't being correctly reset, but
it still doesn't work after a cold restart.  I tried running "usbd -dv"
and nothing is output as I plug in or unplug any device.  One time after
warm booting into 5.5 from 5.1, the already-plugged-in mouse was
recognized on boot but subsequent unplugs and replugs went unnoticed.

Any suggestions?  I plan on trying all the 5.x series until I can nail
down where it breaks, but I have limited physical access to the machine.
Below is my dmesg.  The board is an Asus A7N8X-E (nForce2) and I have
another almost identical one at home running 5.4 whose USB works like a

-- Rick C. Petty

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.5-STABLE #2: Fri Dec 22 01:12:01 CST 2006
    rick at myhostname:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm)  (1730.72-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x6a0  Stepping = 0
  AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory  = 1610547200 (1535 MB)
avail memory = 1568509952 (1495 MB)
mptable_probe: Unable to map end of MP Config Table
ioapic0 <Version 1.1> irqs 0-23 on motherboard
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <Nvidia AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <NVIDIA nForce2 AGP Controller> mem 0xc0000000-0xcfffffff at device 0.0 on pci0
pci0: <memory, RAM> at device 0.1 (no driver attached)
pci0: <memory, RAM> at device 0.2 (no driver attached)
pci0: <memory, RAM> at device 0.3 (no driver attached)
pci0: <memory, RAM> at device 0.4 (no driver attached)
pci0: <memory, RAM> at device 0.5 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xdd080000-0xdd080fff irq 22 at device 2.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xdd083000-0xdd083fff at device 2.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
pci0: <serial bus, USB> at device 2.2 (no driver attached)
pci0: <network, ethernet> at device 4.0 (no driver attached)
pci0: <multimedia, audio> at device 5.0 (no driver attached)
pci0: <multimedia, audio> at device 6.0 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> at device 8.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 6.0 (no driver attached)
rl0: <RealTek 8139 10/100BaseTX> port 0x9000-0x90ff mem 0xda000000-0xda0000ff irq 19 at device 7.0 on pci1
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:48:54:84:17:1d
ahc0: <Adaptec 2940 SCSI adapter> port 0x9400-0x94ff mem 0xda001000-0xda001fff irq 17 at device 9.0 on pci1
aic7870: Single Channel A, SCSI Id=7, 16/253 SCBs
atapci0: <nVidia nForce2 UDMA133 controller> port 0xf000-0xf00f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 9.0 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
pcib2: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci2: <ACPI PCI bus> on pcib2
xl0: <3Com 3c920B-EMB Integrated Fast Etherlink XL> port 0xa000-0xa07f mem 0xdc000000-0xdc00007f irq 20 at device 1.0 on pci2
miibus1: <MII bus> on xl0
acphy0: <AC101L 10/100 media interface> on miibus1
acphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
xl0: Ethernet address: 00:26:54:0e:9e:8f
fwohci0: <1394 Open Host Controller Interface> mem 0xdd087000-0xdd08703f,0xdd086000-0xdd0867ff irq 20 at device 13.0 on pci0
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:e0:18:00:00:24:35:8b
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:e0:18:24:35:8b
fwe0: Ethernet address: 02:e0:18:24:35:8b
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
fwohci0: phy int
pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib3
speaker0: <PC speaker> port 0x61 on acpi0
fdc0: <floppy drive controller> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <ECP parallel printer port> port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppbus0: IEEE1284 device found /NIBBLE
Probing for PnP devices on ppbus0:
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
orm0: <ISA Option ROMs> at iomem 0xd9000-0xd97ff,0xd6000-0xd87ff,0xd4000-0xd57ff,0xd0000-0xd3fff,0xc0000-0xcf7ff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1730724432 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 57278MB <SAMSUNG SV6004H/PY100-10> [116375/16/63] at ata0-master UDMA100
ad1: 57278MB <SAMSUNG SV6004H/PY100-10> [116375/16/63] at ata0-slave UDMA100
ad2: 58623MB <Maxtor 96147U8/BAC51KJ0> [119108/16/63] at ata1-master UDMA66
acd0: CDRW <CD-RW IDE5224/VER 000O> at ata1-slave UDMA33
GEOM_MIRROR: Device gm0 created (id=3973574214).
GEOM_MIRROR: Device gm0: provider ad0 detected.
GEOM_MIRROR: Device gm0: provider ad1 detected.
GEOM_MIRROR: Device gm0: provider ad1 activated.
GEOM_MIRROR: Device gm0: provider ad0 activated.
GEOM_MIRROR: Device gm0: provider mirror/gm0 launched.
pass0 at ahc0 bus 0 target 6 lun 0
pass0: <SCANNER  1.02> Fixed Scanner SCSI-CCS device 
pass0: 3.300MB/s transfers
Mounting root from ufs:/dev/mirror/gm0s1a
Pre-seeding PRNG:
Loading configuration files.
Entropy harvesting:
swapon: adding /dev/mirror/gm0s1b as swap device
Starting file system checks:
/dev/mirror/gm0s1a: clean, 479282 free (610 frags, 59834 blocks, 0.1% fragmentation)
/dev/mirror/gm0s1d: clean, 1013008 free (56 frags, 126619 blocks, 0.0% fragmentation)
/dev/mirror/gm0s1e: clean, 986255 free (231 frags, 123253 blocks, 0.0% fragmentation)
/dev/mirror/gm0s1f: clean, 2664271 free (41943 frags, 327791 blocks, 0.8% fragmentation)
/dev/mirror/gm0s1g: clean, 18974819 free (843 frags, 2371747 blocks, 0.0% fragmentation)
Setting hostname: myhostname.
	inet netmask 0xffffff00 broadcast
	inet6 fe80::226:54ff:fe0e:9e8f%xl0 prefixlen 64 tentative scopeid 0x2 
	ether 00:26:54:0e:9e:8f
	media: Ethernet autoselect (none)
	status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
	inet netmask 0xff000000 
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5 
ipfw2 initialized, divert disabled, rule-based forwarding disabled, default to deny, logging disabled
Flushed all rules.
Invalid argument
00100 allow ip from any to any via lo0
00200 deny ip from any to
00300 deny ip from to any
65000 allow ip from any to any
Firewall rules loaded, starting divert daemons:
Unable to create divert socket.
Protocol not supported

Starting dhclient.
	inet6 fe80::248:54ff:fe84:171d%rl0 prefixlen 64 scopeid 0x1 
	inet netmask 0xffffffe0 broadcast
	ether 00:48:54:84:17:1d
	media: Ethernet autoselect (100baseTX <full-duplex>)
	status: active
Additional routing options:
 IP gateway=YES
Starting devd.
Mounting NFS file systems:
Starting syslogd.
Setting date via ntp.
Looking for host and service ntp
host found :
22 Dec 01:37:00 ntpdate[342]: adjust time server offset -0.414642 sec
ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/X11R6/lib /usr/local/lib /usr/local/libdata/ldconfig/portupgrade
a.out ldconfig path: /usr/lib/aout /usr/lib/compat/aout
Starting usbd.
Starting local daemons:
Starting lpd.
Updating motd
Configuring syscons:
Starting sshd.
Starting sendmail.
Initial i386 initialization:
Additional ABI support:
Starting cron.
Local package initialization:
Starting openvpn.
Additional TCP options:
Starting moused:
unable to open /dev/psm0: No such file or directory

Starting background file system checks in 60 seconds.

Fri Dec 22 01:37:05 CST 2006

More information about the freebsd-hardware mailing list