ASUS V9400 video card prevents FreeBSD from booting

Jordon Hofer bsdlist at
Thu Apr 14 20:13:39 PDT 2005

Greetings.  I recently discovered why FreeBSD quit working on my computer.
When I replaced my GeForce 2 MX400 with a GeForce MX 4000-based card from
ASUS (The X Series V9400 with 64 meg of RAM), FreeBSD no longer boots.  For
what it's worth, the contents of my computer are as follows:

Dual P3-1.4 Tualatin procs in a TYAN mobo
1 gig RAM
Adaptec 39160
  -9 gig Cheetah (Windows 2k install)
  -18 gig Cheetah (NTFS)
  -4 gig UltraStar (i dont even remember whats on this one...)
  -Plextor CDRW
  -Zip Drive
Built-in IDE controller
  -40 gig Maxtor (this drive is for FreeBSD)
  -Plextor DVDRW
SB Audigy
Netgear NIC
Belkin USB2.0 card


The long story is that I had FreeBSD 5.3 on the 40 gig drive from an
install/update/rebuild I did a while back.  My dual-boot setup is pretty
unique in that I either have the 40 gig drive plugged in or I have the SCSI
drives plugged in to keep the two systems isolated.  I gave DragonflyBSD a
try recently and found that it wouldd hang during the boot sequence.  I then
tried booting the BSD install I already had and found that it hung too.  I
tried booting the 5.3 install CD and got the same results.  After lots of
testing, including pulling out all hardware that wasnt essential to boot, I
finally remembered that I had recently replaced video cards in favor of one
with DVI support for my new LCD monitor.  After I put the old video card
back in, the 5.3 cd booted just fine.  I just tried booting 4.11 (from a
real BSDmall-purchased, honest-to-goodness, ours-goes-to-eleven cd and dvd)
and got the same results.

I really dont know how to proceed from here.  If there is any other trick or
way to get info to help the developers recognize this hardware and/or what
is causing it to crash the system, I'm willing to help.


Other interesting things I noticed:

 -Both win2k and bsd5.3 seem to see a firewire adapter on this video card
even though there is no firewire connector on it.

 -I got halfway through typing out this email last week when win2k took a
huge dump and the only thing saving me from a reinstall was SpinRite 6.

 -Yes, I did try booting 5.3 with different options from the menu: verbose
mode, ACPI, etc...  When in non-verbose mode, the last thing I saw was the
waiting 15 sec for SCSI devices message.  In verbose mode, I saw a few
messages beyond that.


More information about the freebsd-hardware mailing list