Marvell 88E8001 on sk0 and RELENG_5_3 - big problems

Daniel Hyde daniel.hyde at
Sun Dec 19 14:39:34 PST 2004

I've got a gigabyte's GA-8IPE775-PRO motherboard which I believe has
the same onboard ethernet card.  I too had zero luck obtaining an IP
address with dhcp (dhclient); however the card works fine if you
forget dhcp and assign it an IP address statically using ifconfig.

If you know the range of IPs your DHCP server reserves for its own use
(or if, like, me, it's your local router that's assigning you an IP in
a private range), just make freebsd claim an IP of its own that's
within the same subnet, but not within DHCP's range, so that it
doesn't clash with other DHCP clients.

For example, my LAN uses 192.168.1.n as its private IP space.  The
gateway/router is, and it assigns IPs 100-253 via DHCP. 
So, I just told ifconfig to grab, and it's fine.

Couldn't give you the exact configuration steps now, as I'm at work
and thus on a different machine.  But if you want them, give me a
holler and I'll see if I can remember what I did when I get home. :)


On Sun, 19 Dec 2004 11:46:58 +0100, craig <craig.freebsd at> wrote:
> > Here's the fix:
> > <>
> >
> > --
> > Michal Belczyk
> do to severe incompatibility problems with my previous motherboard's IDE and fbsd5.3, i recently purchased
> a new gigabyte 865PE, complete with onboard marvell nic. :(
> from dmesg (after applying identifying patch)
> ----
> skc0: <Marvell Gigabit Ethernet> port 0xac00-0xacff mem 0xfb000000-0xfb003fff irq 20 at device 9.0 on pci2
> skc0: Yukon Gigabit Ethernet 10/100/1000Base-T Adapter
> skc0: PN: Yukon 88E8001
> skc0: EC: Rev. 1.3
> skc0: MN: Marvell
> skc0: SN: AbCdEfG5ca025
> sk0: <Marvell Semiconductor, Inc. Yukon> on skc0
> sk0: Ethernet address: 00:0f:ea:5c:a0:25
> miibus0: <MII bus> on sk0
> ----
> unfortuantely, this motherboard too has severe problems.
> although the nic is recognised at install/boot, it simply *refuses* to come up. dhclient just draws a blank.
> i have tried to ifconfig sk0 up and down a few times, but makes no difference.
> i tried to apply Michal's above patch off an absolute fresh install. ie. the *very* first thing i did
> sadly, only 1 of the 2 chunks succeeded.
> from if_sk.c.rej
> ***************
> *** 2425,2431 ****
>         /* serial mode register */
>         DPRINTFN(6, ("sk_init_yukon: 9\n"));
>         SK_YU_WRITE_2(sc_if, YUKON_SMR, YU_SMR_DATA_BLIND(0x1c) |
> -                     YU_SMR_MFL_VLAN | YU_SMR_IPG_DATA(0x1e));
>         DPRINTFN(6, ("sk_init_yukon: 10\n"));
>         /* Setup Yukon's address */--- 2425,2432 ----
>         /* serial mode register */
>         DPRINTFN(6, ("sk_init_yukon: 9\n"));
>         SK_YU_WRITE_2(sc_if, YUKON_SMR, YU_SMR_DATA_BLIND(0x1c) |
> +                     YU_SMR_MFL_VLAN | YU_SMR_MFL_JUMBO |
> +                     YU_SMR_IPG_DATA(0x1e));
>         DPRINTFN(6, ("sk_init_yukon: 10\n"));
>         /* Setup Yukon's address */
> ---
> note, i cannot cvsup to latest RLEENG_5, because i have no network! :(
> any ideas on what to do from here?
> although the patch did not work automatically, i could manually insert the code,
> but i am well aware of the problems that may cause!
> if anyone (in europe) is able to help me solve this issue, i will gladly send them my old ASRock PE ProHT motherboard!
> its in perfect condition and works fine with freebsd4.10 - tragically, 5.3 refuses to work with the
> onboard sis IDE controller...
> much thanks,
> ---
> craig.freebsd at
> _______________________________________________
> freebsd-hardware at mailing list
> To unsubscribe, send any mail to "freebsd-hardware-unsubscribe at"

More information about the freebsd-hardware mailing list