How to receive BIOS console redirection?

Patrick Hurrelmann outi at
Sun Aug 15 05:29:56 PDT 2004

On Sun, 15 Aug 2004 21:09:12 +0900
Hiroharu Tamaru <tamaru at> wrote:

> At Sat, 14 Aug 2004 02:08:18 +0900, Hiroharu Tamaru wrote:
> > I have a Supermicrio P4SC8 motherboard and I want to receive
> > its BIOS console redirect output on another FreeBSD box.
> > The motherboard is checking for *something* to see if a
> > serial terminal is attached, and rejects the link.
> > 
> > I tried 'tip com1' with an /etc/remote setup of
> > 
> > com1:dv=/dev/cuaa0:br#115200:pa=none:
> > 
> > and ports/comms/kermit with 
> > 
> > set line /dev/cuaa0
> > set speed 115200
> > set carrier-watch off
> > connect
> > 
> > and in both cases, the motherboard times out and abandons
> > the redirection.
> Thank you for those who replied to me off-list.
> Encouraged by some working examples, I retried the
> investigation, and now I figured out what was wrong with my
> setup.
> The motherboard seems to be checking for some terminal
> escape sequences.  At first I was working on FreeBSD console
> (TERM=cons25), and that was the cause of failure.  Then I
> tried it from xterm, and it successfully started to
> redirect.  But that was not the end of the story ;-p
> With xterm I could get console messages redirected, but I
> couldn't enter the BIOS setup menus.  It was not reading the
> "DEL" key that I typed.  So then I changed to screen
> (ports/misc/screen), and finally I can enter the BIOS menues
> and all.
> So to summarize, when I work inside screen, both tip and
> kermit worked well with the config shown above.
> cu -s 115200 -l /dev/cuaa0
> also worked well.  I was also sugested with minicom, but
> that I could not configure well to get everything working
> (it has many features and I didn't look into it that much).
> I still cannot enter the Intel NIC's setup menu, which is
> initiated with Ctrl-S.  And for 3ware RAID BIOS (entered
> with Alt-3), the menu is entered (as verified on video
> console), but the output is not redirected to the serial
> port, though, the keys I type on the serial side are sent
> and recoganized by the RAID BIOS.  But I'd say those are
> another story, and I'm happy that I can fiddle with the main
> BIOS setup for now.
> Thank you very much for your help.
> -- 
> Hiroharu Tamaru

Thanks for this tip! I'll try that, as is have the same problems with my Siemens Primergy 470 and console redirection. I see all messages, but i cannot get into system bios (DEL-Key), but i get into Symbios scsi-bios, but console is not redirected. It stays on the video-terminal.

Would be great to access system bios ;)

Patrick Hurrelmann         | "Programming today is a race between software
Mannheim, Germany          |  engineers striving to build bigger and better 
                           |  idiot-proof programs, and the Universe trying
outi at      |  to produce bigger and better idiots. So far,          |  the Universe is winning."         - Rich Cook

More information about the freebsd-hardware mailing list