[CFR] Adding a function to rtld-elf.so, how to handle Symbol.map?

Ian Lepore ian at FreeBSD.org
Fri Jul 18 13:24:08 UTC 2014


On Fri, 2014-07-18 at 11:14 +0300, Konstantin Belousov wrote:
> On Thu, Jul 17, 2014 at 06:17:41PM -0600, Ian Lepore wrote:
> > On Thu, 2014-07-17 at 20:29 +0300, Konstantin Belousov wrote:
> > > On Thu, Jul 17, 2014 at 11:09:50AM -0600, Ian Lepore wrote:
> > > > On Thu, 2014-07-17 at 03:45 +0300, Konstantin Belousov wrote:
> > > > > On Wed, Jul 16, 2014 at 03:23:53PM -0600, Ian Lepore wrote:
> > > > [snip]
> > 
> > > > I did some looking around and Netbsd, Android, and Risc Os all
> > > > implemented this in their dynamic loaders, so that seemed like the way
> > > > to go.  Android actually puts a function with this __gnu name in its
> > > > libc, but all that function does is calls dl_unwind_find_exidx() which
> > > > is implemented in their loader.
> > > > 
> > > > I've just discovered that the arm unwind support code that will arrive
> > > > as part of clang 3.5 appears to assume the Android way of things unless
> > > > __LINUX__ is defined, so maybe it would be good to follow that model
> > > > ourselves and add a dl_unwind_find_exidx() stub to libc/gen/dlfcn.c and
> > > > name the new implementation in ld-elf to match.
> > > I think that Android/__LINUX__ combination does the right thing, by
> > > providing the symbol in libc. A libc implementation does not need any
> > > additional service from rtld, except already existing _rtld_addr_phdr().
> > > 
> > 
> > Android provides a stub of dl_unwind_find_exidx() in libdl and the
> > shared-object implementation in the dynamic linker.  What it puts in
> > libc is the __gnu_Unwind_Find_exidx() symbol, which just calls through
> > to the dl_unwind_find_exidx() implementation in the dynamic linker.
> > 
> > That aside, I've reworked my code so it all lives in libc instead of
> > rtld, as you suggested.  It seems to work fine, and I guess I'm agnostic
> > about whether we're exporting a new function from libc versus rtld.  It
> > seems a bit strange to me to have just one dl_something() function with
> > its shared/dynamic implementation in libc, while all the other functions
> > with dl-prefix names are implemented in rtld.  But not so weird that
> > it's a big deal.
> The new patch is fine with me.  
> 
> Could you, please, comment why did you decided to export the
> dl_unwind_find_exidx alias ? It was absent in the original patch,
> and from your description, it seems to be an implementation detail
> on Linux.

I think you might have misunderstood what I said earlier.  According to
comments in some clang 3.5 sources I saw, the clang project considers
dl_unwind_find_exidx() to be "the BSD interface" for finding the exidx
data.  They fall back to the gnu name only when clang is compiled with
__LINUX__ defined.  By providing the functionality with this name, clang
3.5 will just work right on freebsd without needing to be modified to
also use the gnu name when __FreeBSD__ is defined.

Android and Netbsd provide dl_unwind_find_exidx(); I haven't checked
other BSDs.  It certainly is a better name for an interface shared by
different toolchains than __gnu_Unwind_Find_exidx(), although we do need
to also provide that symbol for anyone using gcc.

-- Ian




More information about the freebsd-hackers mailing list