[SOLVED]Re: 64bit build errors - use gcc46

Da Rock freebsd-hackers at herveybayaustralia.com.au
Thu Dec 8 06:08:01 UTC 2011

On 12/08/11 08:33, Da Rock wrote:
> On 12/08/11 08:31, Da Rock wrote:
>> On 12/08/11 05:47, Mike Meyer wrote:
>>> On Wed, 7 Dec 2011 12:17:57 +0000
>>> Tom Evans<tevans.uk at googlemail.com>  wrote:
>>>> The way I understand it is that they use compiler/assembler features
>>>> that did not exist in the version of binutils that is in base.
>>> Which begs the question - why isn't the new version of the tools
>>> (provided by ports) listed in BUILDDEPENDS in the port, then?
>> I'm not building the port. This is my own build, so the builddepends 
>> isn't existent.
> Hence hackers@, else I would have posted ports@
Just to let the list know, I changed as - ./configure 
--as=/usr/local/bin/as. I still had the exact same error oddly enough.

I then had to install gcc46; and the error changed.

I then had to update the configure script to comment out the v4l 
videodev headers (weird). Bingo! I had success.

So, it begs the question did the as option change things? Or does gcc46 
imply the use of it anyway?

I'll have to try again without the option to see for sure, but for now I 
have another project that I need to keep the status quo for.

More information about the freebsd-hackers mailing list