pkgdb failures

Yuri yuri at
Thu Nov 29 18:11:10 PST 2007

I deleted this file: /var/db/pkg/pkgdb.db and then pkgdb -fu succeeded.
But next time I ran I got the same error with /usr/ports/INDEX-7.db.
Then this error disappear.

So it's most likely the bug with Berkeley DB.
Anybody else has these kind of problems?


Quoting Yuri <yuri at>:

> While doing portupgrade I am sporadically getting the error like below.
> After I ran 'pkgdb -fu' few times and this cured tye problem. But then
> after
> a while of portupgrade run I now get the error:
> >pkgdb -fu
> >--->  Updating the pkgdb
> >[Rebuilding the pkgdb <format:bdb_btree> in /var/db/pkg ...
> /var/db/pkg/pkgdb.db: >unexpected file type or format -- Invalid argument:
> Cannot update the pkgdb!]
> man pkgdb says:
>      Sometimes a database may get corrupt, and the pkgtools commands may
> abort
>      with a segmentation fault.  In such cases, run ``pkgdb -fu'' to
> rebuild
>      the database, and the problems should go away.
> So what should I do now to upgrade ports?
> Yuri
> -- error log during portupgrade --
> /var/db/pkg/pkgdb.db: unexpected file type or format -- Invalid argument
> ** Command failed [exit code 1]: /usr/local/sbin/pkgdb -aFOQ
> --->  Skipping 'net/openldap23-client'
> --->  Reinstalling 'tcl-8.4.16,1' (lang/tcl84)


More information about the freebsd-hackers mailing list