pppoe - nmap - No buffer space available

pilax at freesurf.fr pilax at freesurf.fr
Tue Sep 16 14:33:07 PDT 2003

Hi all

I've got a pppoe gateway with freebsd 5.1-release and two nics : a lan nic
(RFC 1918) and a pppoe nic.
(the same thing append with a 4.7-release...and older versions of nmap)

When I launch nmap to test a machine on the inside : fine !
But when I launch nmap to test a machine on the outside (via tun0) I've got
this message :
---------------- snip ------------------------
nmap -sS -O -vv -r -P0 X.X.X.X

Starting nmap 3.45 ( http://www.insecure.org/nmap/ ) at 2003-09-16 23:03
Host X.X.X.X appears to be up ... good.
Initiating SYN Stealth Scan against X.X.X.X at 23:03
Adding open port 22/tcp
sendto in send_tcp_raw: sendto(3, packet, 40, 0, X.X.X.X, 16) => No buffer
space available
Sleeping 15 seconds then retrying
---------------- snip ------------------------

Here is what I tried :
Switch nic (fxp0 <-> xl0)
Tune kern.ipc.nmbufs
Raise kern.ipc.maxsockets above 35000
see netstat -m (seems regular)

According to tcpdump nmap stop running after port 230.

I've also tried the mailing-lists archives, the web and google groups :

Which informations do I provide you to help me ?


Ce service de mailing vous est offert par http://www.freesurf.fr.
FreeSurf, votre acces ADSL a partir de 29 euros/mois

More information about the freebsd-hackers mailing list