Evolution does not start anymore after an upgrade

Jeremy Messenger mezz.freebsd at gmail.com
Fri Apr 13 13:46:38 UTC 2012

On Wed, Apr 11, 2012 at 9:02 PM, Erich Dollansky
<erichfreebsdlist at ovitrap.com> wrote:
> Hi,
> On Wednesday 11 April 2012 20:56:13 Jeremy Messenger wrote:
>> On Tue, Apr 10, 2012 at 8:23 PM, Erich Dollansky
>> <erichfreebsdlist at ovitrap.com> wrote:
>> >
>> > (evolution:23621): GConf-CRITICAL **: gconf_schema_get_type: assertion `schema != NULL' failed
>> >
>> > (evolution:23621): GConf-CRITICAL **: gconf_schema_get_default_value: assertion `schema != NULL' failed
>> >
>> > (evolution:23621): GConf-CRITICAL **: gconf_value_new: assertion `GCONF_VALUE_TYPE_VALID(type)' failed
>> >
>> > evolution-shell-ERROR **: Unable to create EShellSettings property for GConf key '/apps/evolution/addressbook/completion/show_address' of type 'invalid'
>> Upgrade from what to? We have no idea what you have done as we haven't
>> commit any of upgrade for months (or a year?).
> -rw-r--r--  1 root   wheel  31781650 Aug 13  2011 evolution-2.32.1_1.tbz
> -rw-r--r--  1 erich  Erich  31784043 Apr  8 13:31 evolution-2.32.1_2.tbz
> I have found these two packages. The last date stamps found stored e-mails are from 04.04.2012. Evolution is not used as the main e-mail client on this machine.
> There was a problem with the machine. It died during a port upgrade leaving it in a but undefined state. After fixing the hardware, I deleted everything (pkg_delete -a), updated the ports tree and started compiling. Ports which did not compile (like evolution) were installed as package.
> As I started from scratch, I believed the notes in UPGRADING should not apply and I ignored all.

Correct, you don't need to follow the UPDATING if you install it from
scratch. But the question is that how did you start it from scratch?

>> > all I found at the Internet was this:
>> >
>> > http://mail.gnome.org/archives/commits-list/2011-November/msg04069.html
>> >
>> > Should I delete the settings and try again?
>> Maybe, try it.
> This did not help.
> Should I try to downgrade?

I don't think it will help, because the change between of
evolution-2.32.1_1 and evolution-2.32.1_2 are for libnotify. Try to
remove ~/.gconf*. Yes it will remove your settings if you have

> I also tried to install from source but I am not able to compile:
> checking for Kerberos 5... ./configure: /usr/local/bin/krb5-config: not found
> configure: error: You specified with krb5, but it was not found.
> ===>  Script "configure" failed unexpectedly.
> Please run the gnomelogalyzer, available from
> gnomelogalyzer is not able to tell what the problem is.
> I tried not to use kerberos from the base system. Could the problem be linked to this?
> I never specified this ' with krb5'. Do you know which port uses this?

make.conf or anywhere? It's supposed to be install security/heimdal if
you have one of define in somewhere.


> Erich

mezz.freebsd at gmail.com - mezz at FreeBSD.org
http://www.FreeBSD.org/gnome/ - gnome at FreeBSD.org

More information about the freebsd-gnome mailing list