ports/140563: net/avahi-app doesn't build - depends on missing "gnome-config"

Joe Marcus Clarke marcus at marcuscom.com
Sun Jan 3 01:13:13 UTC 2010

On Sat, 2010-01-02 at 17:03 -0800, Ronald F. Guilmette wrote:
> In message <1262478298.16768.45.camel at shumai.marcuscom.com>, you wrote:
> >I don't know what all of these variables control, but I do know that
> >pkg-config is behaving as if you typed:
> >
> >pkg-config -- dbus-1 --modversion
> Well, I tried this again, just to be sure that I didn't make some stupid
> mistake, e.g. while cutting and pasting what you told me to do:
>   pkg-config dbus-1 --modversion --debug
> When I did this again, once again I got just the same two errors about
> gnome-config as before.  However, noting (as I did) that in the above
> command, the options did NOTR appear before the nonoption args (which
> is counter to POSIX rules for commands) I decided to try this instead/also:
>    pkg-config --modversion --debug dbus-1
> Now *that* command produces a LOT of debugging output.
> Hummm.... I have encountered something similar to this situation before,
> with sopme other package/port in the past that I was also having trouble
> building.  It tried to invoke something... I forget precisely what now...
> maybe bison... but as in this case, it did so in a way that provided non-
> option arguments _before_ some option arguments.
> Hummm... no.  It wasn't bison.  It was something else.  I forget what now
> but I could go back and look it up.  It was somthing needed by something that
> was needed in order to build "nmh".  Anyway, the guy who was the maintainer
> never could reproduce the problem that I was seeing (and he wasn't nearly
> as helpful or caring as you) so he just (arrogantly?) closed the PR.
> Now however I'm thinking that maybe, just maybe, the fact that I use
> /bin/tcsh rather than /bin/csh may perhaps ... no... nevermind.  I
> just checked and even under /bin/csh _and_ /bin/sh also, the behavior
> is the same for:
>    pkg-config dbus-1 --modversion --debug
> i.e. just two error messages about gnome-config... *however* as I've said,
> putting the options befire the non-option arguments seems to make an
> enormous differece in terms of the output, and the command rewritten to:
>    pkg-config --modversion --debug dbus-1
> seems to produce a whole lotta output.  (I have no idea if any of it is
> in any sense "correct" or not, but at least there is a lot of it.)
> So now, is THIS my solution? Do I just simply need to find the place in
> the avahi-app Makefile(s) where the pgk-config command is being invoked,
> and then re-arrange things so that the options come before non-option
> args?

This isn't a solution.  This just reinforces the fact that your system
has a problem.  Now that I look again, you have POSIXLY_CORRECT set in
your environment.  This is the cause of your problem.  Remove this
variable, and popt-based applications will work the way they were


PGP Key : http://www.marcuscom.com/pgp.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: This is a digitally signed message part
Url : http://lists.freebsd.org/pipermail/freebsd-gnome/attachments/20100103/a1b1b227/attachment.pgp

More information about the freebsd-gnome mailing list