Erratic errors with evolution-2.26

Peter Ulrich Kruppa ulrich at pukruppa.net
Mon Apr 20 18:32:12 UTC 2009


Am Montag, den 20.04.2009, 13:37 -0400 schrieb Joe Marcus Clarke: 
> On Mon, 2009-04-20 at 19:25 +0200, Peter Ulrich Kruppa wrote:
> > Hi,
> > 
> > since I am using evolution-2.26, bug-buddy will _sometimes_ be started
> > when an email arrives. It says an unknown application failed and
> > delivers a trace like this one:
> 
> This isn't a stack trace.  You need to run Evolution in gdb, then follow
> the documentation at http://www.freebsd.org/gnome/docs/bugging.html to
> get a real stack trace with debugging symbols when the crash occurs.
I tried that, but I don't believe it will be of any use, since it isn't
evo itself that crashes - bug-buddy says it doesn't know this crashing
application.

Anyway, I ran evo from gdb and got this:
-------------------------------------
(gdb) run
Starting program: /usr/local/bin/evolution 
[New LWP 100159]
[New Thread 0x809f020b0 (LWP 100159)]
/home/ulrich/.gtkrc-2.0:2: Include-Datei konnte nicht gefunden werden:
».gtkrc-2.0-scrollbar_cog«
** (evolution:57108): DEBUG: mailto URL command: evolution %s
** (evolution:57108): DEBUG: mailto URL program: evolution
[New Thread 0x809f03050 (LWP 100173)]
[New Thread 0x809f031e0 (LWP 100174)]
[New Thread 0x809f03370 (LWP 100177)]
[New Thread 0x809f03690 (LWP 100178)]
[New Thread 0x809f03820 (LWP 100188)]
[New Thread 0x809f03cd0 (LWP 100190)]
[Thread 0x809f03370 (LWP 100177) exited]
[Thread 0x809f03cd0 (LWP 100190) exited]
[New Thread 0x809f03ff0 (LWP 100205)]
[New Thread 0x809f04180 (LWP 100206)]
[New Thread 0x809f04310 (LWP 100207)]
[New Thread 0x809f044a0 (LWP 100208)]
[Thread 0x809f03ff0 (LWP 100205) exited]
[Thread 0x809f04310 (LWP 100207) exited]
[Thread 0x809f044a0 (LWP 100208) exited]
[Thread 0x809f04180 (LWP 100206) exited]
[New Thread 0x809f03370 (LWP 100177)]
[New Thread 0x809f03cd0 (LWP 100190)]
[Thread 0x809f03370 (LWP 100177) exited]
[Thread 0x809f03cd0 (LWP 100190) exited]
[New Thread 0x809f03ff0 (LWP 100177)]
[Thread 0x809f03ff0 (LWP 100177) exited]
[New Thread 0x809f04310 (LWP 100177)]
[New Thread 0x809f044a0 (LWP 100190)]
[New Thread 0x809f04180 (LWP 100205)]
[New Thread 0x809f05da0 (LWP 100206)]
[New Thread 0x809f05f30 (LWP 100207)]
[Thread 0x809f05f30 (LWP 100207) exited]
[New Thread 0x809f060c0 (LWP 100207)]
[Thread 0x809f060c0 (LWP 100207) exited]
[Thread 0x809f05da0 (LWP 100206) exited]
[New Thread 0x809f03370 (LWP 100206)]
[Thread 0x809f03370 (LWP 100206) exited]
[New Thread 0x809f03cd0 (LWP 100206)]
[Thread 0x809f03cd0 (LWP 100206) exited]
[New Thread 0x809f03ff0 (LWP 100206)]
[New Thread 0x809f05f30 (LWP 100207)]
[New Thread 0x809f060c0 (LWP 100208)]
[Thread 0x809f05f30 (LWP 100207) exited]
[New Thread 0x809f05da0 (LWP 100207)]
[Thread 0x809f04310 (LWP 100177) exited]
[Thread 0x809f060c0 (LWP 100208) exited]
[Thread 0x809f03ff0 (LWP 100206) exited]
[Thread 0x809f05da0 (LWP 100207) exited]
[New Thread 0x809f03370 (LWP 100177)]
[New Thread 0x809f03cd0 (LWP 100206)]
[Thread 0x809f03cd0 (LWP 100206) exited]
[New Thread 0x809f05f30 (LWP 100206)]
[Thread 0x809f05f30 (LWP 100206) exited]
[New Thread 0x809f04310 (LWP 100206)]
[Thread 0x809f04310 (LWP 100206) exited]
[New Thread 0x809f060c0 (LWP 100206)]
[Thread 0x809f060c0 (LWP 100206) exited]
[Thread 0x809f03370 (LWP 100177) exited]

Program exited normally.
(gdb) thread apply all bt
(gdb) quit
-------------------------------------------------------

When an email arrived and bug-buddy came up, I finished evo.

I wonder: Could it be one of evo's plugins that trigger the
crash-message - or some other dependent application? 

Greetings

Uli.

> 
> Joe
> 
> > 
> > 	-----------------------------------------------
> > System: FreeBSD 7.2-PRERELEASE FreeBSD 7.2-PRERELEASE #0: Sun Apr 19
> > 16:19:24 CEST 2009     ***:/usr/obj/usr/src/sys/*** amd64
> > X Vendor: The X.Org Foundation
> > X Vendor Release: 10600000
> > Selinux: No
> > Accessibility: Disabled
> > GTK+ Theme: Clearlooks
> > Icon Theme: gnome
> > GTK+ Modules: canberra-gtk-module, gnomebreakpad
> > 
> > Memory status: size: 136597504 vsize: 136597504 resident: 27250688
> > share: 156515109 rss: 27250688 rss_rlim: 6653
> > CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0
> > timeout: 0 it_real_value: 0 frequency: 133
> > 
> > 
> > 
> > ---- Critical and fatal warnings logged during execution ----
> > 
> > ** GLib **: gmem.c:136: failed to allocate 64 bytes 
> > 	---------------------------------------------------------
> > 
> > As I wrote, this thing isn't produced every time an email arrives, just
> > sometimes. Also I can't see any application crash: it's just annoying to
> > click away bug-buddy 15 times a day.
> > This problem persists although I forced a complete portupgrade and even
> > after I installed evolution-2.26.1.1 .
> > 
> > Can anybody else see this or should I just kill bugs-bunny?
> > 
> > Greetings
> > 
> > Uli. 
> > 
> > _______________________________________________
> > freebsd-gnome at freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> > To unsubscribe, send any mail to "freebsd-gnome-unsubscribe at freebsd.org"
> > 


More information about the freebsd-gnome mailing list