Upgrading devel/icu (HEADS UP)

Mikhail Teterin mi+mx at aldan.algebra.com
Mon Sep 18 15:15:40 PDT 2006


A number of people have reported crashes in the devel/icu's self-tests.
One such failure is even occuring on the packages-building cluster (on
FreeBSD/ia64).

I'd like to upgrade the port to the vendor's most recent version, 3.6 --
software authors dislike having to delve into earlier versions...

Most of the things should be unaffected, but some of you (incorrectly)
demand a particular shared library version in the list of dependencies:

databases/postgresql80-server/Makefile:LIB_DEPENDS=     icudata.34:${PORTSDIR}/devel/icu
databases/postgresql81-server/Makefile:LIB_DEPENDS=     icudata.34:${PORTSDIR}/devel/icu
devel/boost/Makefile:LIB_DEPENDS+=      icuuc.34:${PORTSDIR}/devel/icu

If you do not object, I intend to fix the above dependencies, commit the
devel/icu upgrade in the next few days and await for the build cluster's
test.

If you have the time and inclination, you can try out the attached patch.

Yours,

	-mi
-------------- next part --------------
A non-text attachment was scrubbed...
Name: icu.patch
Type: text/x-diff
Size: 5653 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-gnome/attachments/20060918/482bedc9/icu-0001.bin


More information about the freebsd-gnome mailing list