epiphany build failure

J. W. Ballantine jwb at homer.att.com
Wed Jul 20 16:46:05 GMT 2005


The "stock" version that one gets with cvsup and marcusmerge.sh,
firefox-1.1.a1_1,1

Jim



----------  In Response to your message -------------

>  Date:  Wed, 20 Jul 2005 11:02:52 -0500
>  To:  "J. W. Ballantine" <jwb at homer.att.com>
>  From:  "Jeremy Messenger" <mezz7 at cox.net>
>  Subject:  Re: epiphany build failure
>
>  On Wed, 20 Jul 2005 08:54:37 -0500, J. W. Ballantine <jwb at homer.att.com>  
>  wrote:
>  
>  > During an attempt to build gnome-devel (marcuscom.com) on a 5-STABLE  
>  > box, one of the
>  > failures I get is www/epiphany (epiphany-1.7.1) (bad C++ code), with the  
>  > compile giving:
>  
>  What's version of Firefox do you have? The firefox-devel (1.1.x) doesn't  
>  work for the other apps, better to use stable version (1.0.x).
>  
>  Cheers,
>  Mezz
>  
>  >  c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../lib -I../../embed -I../..  
>  > -I/usr/X11R6/include/firefox -I/usr/X11R6/include/firefox/cap
>  > s -I/usr/X11R6/include/firefox/chardet  
>  > -I/usr/X11R6/include/firefox/commandhandler  
>  > -I/usr/X11R6/include/firefox/content -I/usr/X11R6
>  > /include/firefox/cookie -I/usr/X11R6/include/firefox/docshell  
>  > -I/usr/X11R6/include/firefox/dom -I/usr/X11R6/include/firefox/exthandl
>  > er -I/usr/X11R6/include/firefox/fastfind  
>  > -I/usr/X11R6/include/firefox/helperAppDlg  
>  > -I/usr/X11R6/include/firefox/gfx -I/usr/X11R6/inc
>  > lude/firefox/history -I/usr/X11R6/include/firefox/js  
>  > -I/usr/X11R6/include/firefox/layout -I/usr/X11R6/include/firefox/locale  
>  > -I/usr/
>  > X11R6/include/firefox/mimetype -I/usr/X11R6/include/firefox/necko  
>  > -I/usr/X11R6/include/firefox/nkcache -I/usr/X11R6/include/firefox/
>  > passwordmgr -I/usr/X11R6/include/firefox/pipboot  
>  > -I/usr/X11R6/include/firefox/pipnss  
>  > -I/usr/X11R6/include/firefox/shistory -I/usr/X1
>  > 1R6/include/firefox/sidebar -I/usr/X11R6/include/firefox/uriloader  
>  > -I/usr/X11R6/include/firefox/uconv -I/usr/X11R6/include/firefox/w
>  > allet -I/usr/X11R6/include/firefox/webbrowserpersist  
>  > -I/usr/X11R6/include/firefox/webbrwsr  
>  > -I/usr/X11R6/include/firefox/widget -I/us
>  > r/X11R6/include/firefox/windowwatcher  
>  > -I/usr/X11R6/include/firefox/xmlextras  
>  > -I/usr/X11R6/include/firefox/xpcom -I/usr/X11R6/include
>  > /firefox/xpconnect -DSHARE_DIR=\"/usr/X11R6/share/gnome/epiphany\"  
>  > -DMOZILLA_HOME=\"/usr/X11R6/lib/firefox\" -DMOZILLA_PREFIX=\"/usr
>  > /X11R6\" -DALLOW_PRIVATE_API -I/usr/local/include -I/usr/X11R6/include  
>  > -I/usr/X11R6/include/firefox/gtkembedmoz -I/usr/X11R6/include
>  > /firefox -I/usr/X11R6/include/firefox/xpcom  
>  > -I/usr/X11R6/include/firefox/string -I/usr/X11R6/include/firefox/nspr  
>  > -DORBIT2=1 -D_REEN
>  > TRANT -DXTHREADS -DXUSE_MTSAFE_API -I/usr/local/include/glib-2.0  
>  > -I/usr/local/lib/glib-2.0/include -I/usr/local/include/atk-1.0 -I/u
>  > sr/local/include/freetype2 -I/usr/local/include  
>  > -I/usr/local/include/cairo -I/usr/local/include/libpng  
>  > -I/usr/local/include/libxml2
>  > -I/usr/local/include/libart-2.0 -I/usr/local/include/orbit-2.0  
>  > -I/usr/local/include/libbonobo-2.0 -I/usr/local/include/bonobo-activa
>  > tion-2.0 -I/usr/X11R6/include/pango-1.0 -I/usr/X11R6/include/gtk-2.0  
>  > -I/usr/X11R6/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/X1
>  > 1R6/include/libgnomeui-2.0 -I/usr/X11R6/include/libgnome-2.0  
>  > -I/usr/X11R6/include/libgnomecanvas-2.0 -I/usr/X11R6/include/gconf/2 -I
>  > /usr/X11R6/include/libbonoboui-2.0 -I/usr/X11R6/include/gnome-vfs-2.0  
>  > -I/usr/X11R6/lib/gnome-vfs-2.0/include -I/usr/X11R6/include/li
>  > bglade-2.0 -I/usr/X11R6/include/gnome-vfs-module-2.0  
>  > -I/usr/X11R6/include/gnome-desktop-2.0  
>  > -I/usr/X11R6/include/startup-notificatio
>  > n-1.0 -fno-rtti -fshort-wchar -O -pipe -MT  
>  > libephymozillaembed_la-MozDownload.lo -MD -MP -MF  
>  > .deps/libephymozillaembed_la-MozDownloa
>  > d.Tpo -c MozDownload.cpp  -fPIC -DPIC -o  
>  > .libs/libephymozillaembed_la-MozDownload.o
>  > MozDownload.cpp: In member function `nsresult  
>  > MozDownload::InitForEmbed(nsIURI*, nsIURI*, const nsAString&,  
>  > nsIMIMEInfo*, PRTime, ns
>  > ILocalFile*, nsICancelable*, MozillaEmbedPersist*, PRInt64)':
>  > MozDownload.cpp:110: error: no matching function for call to  
>  > `MozDownload::Init(nsIURI*&, nsIURI*&, const nsAString&, nsIMIMEInfo*&,
>  >  PRTime&, nsILocalFile*&, nsICancelable*&)'
>  > MozDownload.h:115: note: candidates are: virtual nsresult  
>  > MozDownload::Init(nsIURI*, nsIURI*, const nsAString&, nsIMIMEInfo*,  
>  > PRTime
>  > , nsICancelable*)
>  > MozDownload.cpp: At global scope:
>  > MozDownload.cpp:144: error: prototype for `nsresult  
>  > MozDownload::Init(nsIURI*, nsIURI*, const nsAString&, nsIMIMEInfo*,  
>  > PRTime, nsIL
>  > ocalFile*, nsICancelable*)' does not match any in class `MozDownload'
>  > MozDownload.h:115: error: candidate is: virtual nsresult  
>  > MozDownload::Init(nsIURI*, nsIURI*, const nsAString&, nsIMIMEInfo*,  
>  > PRTime,
>  >  nsICancelable*)
>  > gmake[4]: *** [libephymozillaembed_la-MozDownload.lo] Error 1
>  > gmake[4]: Leaving directory  
>  > `/usr/ports/www/epiphany/work/epiphany-1.7.2/embed/mozilla'
>  > gmake[3]: *** [all-recursive] Error 1
>  > gmake[3]: Leaving directory  
>  > `/usr/ports/www/epiphany/work/epiphany-1.7.2/embed'
>  > gmake[2]: *** [all] Error 2
>  > gmake[2]: Leaving directory  
>  > `/usr/ports/www/epiphany/work/epiphany-1.7.2/embed'
>  > gmake[1]: *** [all-recursive] Error 1
>  > gmake[1]: Leaving directory `/usr/ports/www/epiphany/work/epiphany-1.7.2'
>  > gmake: *** [all] Error 2
>  > *** Error code 2
>  >
>  >
>  > Now I don't seem to be getting this on another box, 5-STABLE with  
>  > gnome-devel also.
>  >
>  > Any ideas on what's causing this.
>  >
>  > Thanks
>  >
>  > Jim
>  
>  
>  -- 
>  mezz7 at cox.net  -  mezz at FreeBSD.org
>  FreeBSD GNOME Team
>  http://www.FreeBSD.org/gnome/  -  gnome at FreeBSD.org
>  




More information about the freebsd-gnome mailing list