How can I debug the gnome-netstatus-applet (2.6.0)?

Jeremy Messenger mezz7 at
Wed Mar 24 12:02:57 PST 2004

On Wed, 24 Mar 2004 14:35:24 -0500, Joe Marcus Clarke 
<marcus at> wrote:

> On Wed, 2004-03-24 at 12:51, Jeremy Messenger wrote:
>> Hello,
>> Current, I am trying to test almost all apps that came with x11/gnome2
>> (2.6.0) by default. The gnome-netstatus-applet doesn't work, so I went 
>> to
>> the propteries and changed it to dc0 then it will crash. I tried to get 
>> it
>> run under gdb, but it will freeze the X even thought if it was in the
>> Fluxbox.
>> Here's what I did:
>> ==========================================
>> % gdb /usr/X11R6/libexec/gnome-netstatus-applet <pid>
>> % cont
>> <output crashed/errors>
>> <X freeze, had to kill it by atl+ctrl+backspace>
>> ==========================================
>> Umm... Maybe, I can try to use another machine and debug it throught SSH
>> to this machine when X freeze.
> It's almost impossible to debug bonobo entities.

It sucks.. I noticed that if I exit GNOME/X and bonobo never exit correct, 
which it still running. I had to kill it by manual. I have no clue how to 
debug or find what problem it is. Hope, it's not same as with the not exit 
shell correct bug.

> However, I found the bug, and fixed it.  Sorry, this was entirely my 
> fault.
> I was the one that wrote the original code.

Yep, that fixed it. Thanks!


> Joe
>> Cheers,
>> Mezz

-- 's moderator, mezz.

More information about the freebsd-gnome mailing list