Franz Klammer klammer at
Wed Jan 21 07:24:52 PST 2004

Jochen Schrader wrote:

>As the error message says I report my problem to you.
>Error Output:
>------ schnipp ---------
>checking what language compliance flags to pass to the C compiler...
>checking locale.h usability... yes
>checking locale.h presence... yes
>checking for locale.h... yes
>checking for LC_MESSAGES... yes
>checking libintl.h usability... yes
>checking libintl.h presence... yes
>checking for libintl.h... yes
>checking for dgettext in libc... no
>checking for bindtextdomain in -lintl... yes
>checking for dgettext in -lintl... yes
>checking for bind_textdomain_codeset... yes
>checking for msgfmt... /usr/local/bin/msgfmt
>checking for dcgettext... yes
>checking for gmsgfmt... /usr/local/bin/msgfmt
>checking for xgettext... /usr/local/bin/xgettext
>checking for catalogs to be installed...  am ar az be bg bn ca cs cy da de
>el es fa fi fr he hi hu id is it ja kn ko li lt lv ml mn mr ms ne nl nn no
>pl pt pt_BR ro ru sk sl sq sr sr at Latn sv ta tr uk vi wa yi zh_CN zh_TW
>checking for pkg-config... /usr/local/bin/pkg-config
>checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
>checking for gethostbyname... yes
>checking for connect... yes
>checking for remove... yes
>checking for shmat... yes
>checking for IceConnectionNumber in -lICE... yes
>checking for libgnomecanvas-2.0 >= 1.116.0                libbonobo-2.0 >=
>2.3.3                  libgnome-2.0 >= 1.116.0                
>bonobo-activation-2.0 >= 1.0.0                  libxml-2.0 >= 2.4.20      
>     gconf-2.0 >= 1.1.9     gtk+-2.0 >= 2.2.0... Requested 'libbonobo-2.0
>>= 2.3.3' but version of libbonobo is 2.2.3
>configure: error: Library requirements (libgnomecanvas-2.0 >= 1.116.0     
>      libbonobo-2.0 >= 2.3.3                   libgnome-2.0 >= 1.116.0    
>           bonobo-activation-2.0 >= 1.0.0                   libxml-2.0 >=
>2.4.20           gconf-2.0 >= 1.1.9               gtk+-2.0 >= 2.2.0) not
>met; consider adjusting the PKG_CONFIG_PATH environment variable if your
>libraries are in a nonstandard prefix so pkg-config can find them.
>===>  Script "configure" failed unexpectedly.
>      Please report the problem to gnome at [maintainer] and attach
>      the
>      "/usr/ports/x11-toolkits/libbonoboui/work/libbonoboui-2.4.3/config.log"
>      including the output of the failure of your make command. Also, it
>      be a good idea to provide an overview of all packages installed on your
>      system (e.g. an `ls /var/db/pkg`).
>*** Error code 1

you must update libbonobo. you can see all your outdated ports that can
result in such an error with the command: pkg_version -l \<

please take also a look at the gnome FAQ you will find a description of 
type of error:

also look at:


>Stop in /usr/ports/x11-toolkits/libbonoboui.
>---- schnapp -----
>Output of 'ls /var/db/pkg':
>----- schnipp -----

<output deleted>

>------ schnapp ------
>I think some package requires an other package version than I have in my
>ports. But this problem is not too important!


More information about the freebsd-gnome mailing list