libxslt build error

Kurt Werle kwerle at
Fri Dec 17 12:34:58 PST 2004

On Dec 17, 2004, at 12:29 PM, Jeremy Messenger wrote:

> On Fri, 17 Dec 2004 12:17:39 -0800, Kurt Werle <kwerle at> 
> wrote:
>> On Dec 17, 2004, at 12:16 PM, Jeremy Messenger wrote:
>>> On Fri, 17 Dec 2004 10:40:13 -0800, Kurt Werle <kwerle at> 
>>> wrote:
>>>> libxslt failed to build with the following error (from 
>>>> /usr/ports... on FreeBSD 4.7):
>>>> checking for libxml libraries >= 2.6.15... configure: error: 
>>>> Version 2.5.8 found. You need at least libxml2 2.6.15 for this 
>>>> version of libxslt
>>>> Looks like one of the makefile depends needs fixing.
>>> No, your machine needs to be fixing. Learn to use portupgrade for 
>>> update all of your apps first, before you can touch port what you 
>>> are trying to install. We have libxml2 2.6.16 in ports tree.
>> I did a cvsup (all of ports) right before building.
> CVSup only merely update your ports tree and don't update your apps 
> what you already have them installed. The portupgrade will update your 
> apps for you by automatic, you can install portupgrade from 
> sysutils/portupgrade.
> You have libxml2 2.5.8, so it's very old like over a year ago or more. 
> You will have to check in /usr/ports/UPDATING, read manpage of 
> portupgrade and google for portupgrade to find few good articles about 
> it. Update your apps that are over a year old won't be fun, I would 
> rebuild/reinstall all apps.

I have already upgraded libxml and libxslt (since reporting the issue).

However, it has been my experience that most packages correctly detect 
which version of a library is required and whether or not it has been 
installed.  libxslt does not seem to do so in this case.

kwerle at
Tired of spam? Control your Mailserver (or .forward)?

More information about the freebsd-gnome mailing list