libxslt build error

Jeremy Messenger mezz7 at
Fri Dec 17 12:29:10 PST 2004

On Fri, 17 Dec 2004 12:17:39 -0800, Kurt Werle <kwerle at> wrote:

> On Dec 17, 2004, at 12:16 PM, Jeremy Messenger wrote:
>> On Fri, 17 Dec 2004 10:40:13 -0800, Kurt Werle <kwerle at> wrote:
>>> libxslt failed to build with the following error (from /usr/ports...  
>>> on FreeBSD 4.7):
>>> checking for libxml libraries >= 2.6.15... configure: error: Version  
>>> 2.5.8 found. You need at least libxml2 2.6.15 for this version of  
>>> libxslt
>>> Looks like one of the makefile depends needs fixing.
>> No, your machine needs to be fixing. Learn to use portupgrade for  
>> update all of your apps first, before you can touch port what you are  
>> trying to install. We have libxml2 2.6.16 in ports tree.
> I did a cvsup (all of ports) right before building.

CVSup only merely update your ports tree and don't update your apps what  
you already have them installed. The portupgrade will update your apps for  
you by automatic, you can install portupgrade from sysutils/portupgrade.

You have libxml2 2.5.8, so it's very old like over a year ago or more. You  
will have to check in /usr/ports/UPDATING, read manpage of portupgrade and  
google for portupgrade to find few good articles about it. Update your  
apps that are over a year old won't be fun, I would rebuild/reinstall all  


>> On another note, we don't support FreeBSD 4.7. It's highly recommend  
>> you to update your FreeBSD too, which we only support 4.10, 5.3,  
>> 4-STABLE, 5-STABLE and 6-CURRENT. If you don't want to update, then  
>> please don't bother to report your bugs in here.
> Thanks.
> Kurt

mezz7 at  -  mezz at
FreeBSD GNOME Team  -  gnome at

More information about the freebsd-gnome mailing list