VirtualBox QT issue

Wayne Sierke ws at
Sun Oct 10 17:31:16 UTC 2010

On Thu, 2010-10-07 at 14:13 -0500, Adam Vande More wrote: 
> Not sure this is technically an emulation issue, but have only encountered
> on Vbox.  The issue goes like this, I run Vbox on another computer and the
> VM's are headless.  Occasionally, I'll start the VirtualBox GUI client
> remotely(ssh -Y) to manage settings, etc.  The remote system also used an
> Nvidia card like my desktop.  This worked well until my board died and I got
> a new one with an integrated ATI RADEON HD 3300 Graphics (RS780).
> Now when I start a VirtualBox remotely, and click on the Settings button of
> any VM, the VirtualBox GUI seg faults with the following error msg:
> Qt WARNING: QGLContext::makeCurrent(): Cannot make invalid context current.
> zsh: segmentation fault  VirtualBox
> if you run "truss VirtualBox" the GUI will not even open with an "Effective
> UID is not root" error.
> The VirtualBox GUI runs properly when it's local, eg on physical
> machine/monitor or over VNC.

I have been running not only the VirtualBox manager but also some VM
instances over a "ssh -Y" connection. It performs very well and I can't
recall ever seeing any hint of the problem you describe. The two systems
could hardly be more different, either, server: Intel Core2 Duo
w/FreeBSD-8.1 amd64 (w/integrated Intel gfx)  vs client: AMD Opteron
w/FreeBSD-7.3 i386 (w/PCIe nVidia gfx).

I've also just noticed that curiously the client machine has lost its
OpenGL functionality:

        Error: glXCreateContext failed
        QGLTempContext: Unable to create GL context.
        Unrecognised OpenGL version

The server isn't currently running an Xserver instance. As far as I can
remember I've been able to use the ssh -Y connection while I've had VMs
actively running in the server's Xserver instance. If you think it's of
interest I can probably verify that a little later. I'll also be aiming
to correct the problem with the OpenGL on the client system in due

Just to be clear, in your case the board that died was the client
machine? How thorough was the effort in recompiling the hierarchy of the
hardware-dependent ports?


More information about the freebsd-emulation mailing list