kernel panic with VirtualBox on -CURRENT

Ivan Voras ivoras at
Thu Jun 18 09:21:35 UTC 2009

Adam K Kirchhoff wrote:
> Ivan Voras wrote:
>> Lucius Windschuh wrote:
>>> 2009/6/17 Adam K Kirchhoff <adamk at>
>>>> Unfortunately, I do not see an option in this computers' BIOS to 
>>>> enable virtualization.  I'm actually trying on a machine at work 
>>>> now, rather than the one I tried at home yesterday, but the results 
>>>> are the same.  This computer actually has as an Intel Core 2 Quad 
>>>> CPU (unlike yesterdays dualcore Xeon).  Is there someway to check if 
>>>> the processors on these machines support the virtualization extensions?
>>>> I also am not able to disable the AMD-V option in VirtualBox.  The 
>>>> check box is selected but greyed out.
>>> "Me too". Same panic on an Atom board (i386 mode). Same greyed out 
>>> checkboxes.
>>> Are you also using i386?
>> Most Atom CPUs don't support hardware virtualization extensions. AFAIK 
>> only the "desktop" variants support it.
> On my machine, it's greyed out as well, which suggests my CPU doesn't 
> support the extensions.  So why would the check box be checked?

I suspect it might be a GUI thing - maybe the tookit has problem 
displaying the "disabled" state.

> Are the extensions necessary to use VirtualBox on FreeBSD at the moment?

If you want to use SMP or AMD64 guests, or need the performance.

> Is there anything else I can test or any more information I can give to 
> figure out why my kernel is panicking with VirtualBox?

Not really if you already tried getting a core dump.

More information about the freebsd-emulation mailing list