Lack of Flash support is no longer acceptable. Bounty established...

Alexander Leidinger Alexander at Leidinger.net
Fri Jun 20 06:39:15 UTC 2008


Quoting John Kozubik <john at kozubik.com> (from Thu, 19 Jun 2008  
14:38:11 -0700 (PDT)):

> First, a bounty has been posted here:
>
> http://blog.kozubik.com/john_kozubik/2007/12/bounty-posted-f.html
>

 From the site:
---snip---
I will pay $200 to whoever can compose a working and stable recipe for  
running Adobe Flash 9 inside of the FreeBSD native version of Opera 9  
on FreeBSD 6.x. This shouldn't be that hard - in fact, there is  
already a linux-flashplugin9 port.
---snip---

Comments from other people with some more money not included here...

And now the sad reality check: linux-flashplugin9 will _never_ work on  
6.x (lack of linux 2.6 emulation, and this is not a MFC candidate).

Getting it to work on 7.x is possible. "All what you need" is  
nspluginwrapper to get it running in the native  
firefox/opera/whatever, and someone who is willing to debug the  
linuxulator (on -current, as there is a more complete 2.6  
compatibility there, and this can be MFCed to 7.x) and find the  
bug/problem which is causing the crashes. Whoever is willing to tackle  
this: head over to emulation@ (CCed) and ask what debugging  
possibilities we have in the linuxulator.

Note: AFAIK linux-flashplugin9 is not completely stable on linux either...

Bye,
Alexander.

-- 
    Leela: Well, goodnight. I'm gonna go make my dinners for the next month
    and freeze them.

http://www.Leidinger.net    Alexander @ Leidinger.net: PGP ID = B0063FE7
http://www.FreeBSD.org       netchild @ FreeBSD.org  : PGP ID = 72077137


More information about the freebsd-emulation mailing list