Signal 12 on simple ldd / Linux

Tuc at T-B-O-H.NET ml at
Thu Sep 27 17:04:30 PDT 2007

> The -R should handle sym links correctly (copy the link itself instead
> of following it), but will break hard links into multiple separate
> files.
	I think I used "-p -r", thats my fault. 
>  > I did the /compat/linux/sbin/ldconfig and it returned fine,
> I usually do '/compat/linux/sbin/ldconfig -r /compat/linux'.
	Thanks. I was going by /etc/rc.d/abi , but did that, and 
tried that too. Same results.
>  > but try to run the program results in my still getting the same error. 
>  > I don't know if its because something in cache somewhere or what now...
>  > Maybe I should do a proper install of linux_base-fc-4 incase, or 
>  > would a reboot first be suggested, or ????
> This seems to confirm (?) that it's not nfs'd /compat/linux.
	Maybe, or maybe whatever I'm doing to violate the poor system
got brought over with it. :) (Sorta joking)
> Move
> away the current linux_base, try a proper install of linux_base, see
> if there are any differences. 
	Will try that later tonite or tomorrow...
> Try a kldunload / kldload of linux &/or
> linprocfs (if loaded). 
	Did linux (I don't have linprocfs on this particular machine)
Unloaded it doesn't understand the elfness, reloaded it "Bad system 
call (core dump)".
> Try a linux.ko from a working system.
	HRMMMMMMMM. I just detected another "3 of these things are not
like the other". The 3 systems that are NFS clients are 5.3-RELEASE-pX
systems... The NFS server, my laptop, the backup server, are all
5.5-{RELEASE|STABLE}..... (And, oddly enough, where it works)
Can i put a linux.ko from a 5.5 on a 5.3, I didn't think so.  The 
other issue is could it be a 5.3 vs 5.5 issue now?

	I've been wanting since forever (And a day and 1/2) to upgrade
to 5.5 on one of the servers. (I've had issues that some of my machines
won't go past 5.3, lockups/etc that seem to get not much attention on 
the questions lists...) Maybe this is a good time to do so?
> If you
> try the reboot and it fixes things, you don't learn a lot.
	I realize, but there have been times where FreeBSD just gets
confused no matter how hard you try and you just have to resort to
a reboot. BELIEVE ME, I hate rebooting these machines. I had to
reboot 6 months ago after an external storage array failure on
the NFS server, and it wasn't pretty. I have to reboot after
I use VMWare 3 on my laptop, otherwise out of the blue after I'm done
anywhere from an hour to 3 days later it'll reboot itself.

			Thanks, Tuc

More information about the freebsd-emulation mailing list