Nvidia LibGL and RELENG_7 linuxulator

Zephiris zephiris at gmail.com
Fri Oct 19 08:03:29 PDT 2007


I've been getting a rather strange issue between Nvidia driver and the
linux compatibility.

I've tried this with default Fedora Core 4 libraries, default 2.4 version
emulation, 2.6.16, FC6, F7, and now Gentoo. With older Linux X11 libraries
(eg, those from ports), anything trying to use Nvidia's libGL that
installs into the linux compat area will crash immediately. To get this
working at all, I had to install the Gentoo linux dist and install with
newer versions of everything (except glibc). 

This will get far enough that it notes things like:
NVIDIA: Direct rendering failed; attempting indirect rendering.

/sbin/modprobe, as per suggestions and documentation, is symlinked
to ../bin/true, and that allows many things to work rather than
complaining that the module can't be loaded. Linux glxgears gets roughly
the same speed as on native host, but Linux glxinfo reports no direct
rendering is enabled, and a number of extensions aren't reported. This
means for basically all Linux games and most 3D apps, they get a small
fraction of the normal speed.

In addition, I have devfs mounted on /compat/linux/dev (also per various
suggestions found), but if I run Linux glxinfo or glxgears or something
else that loads OpenGL several times, but keeps complaining that it can't
enable direct rendering, it erases nvidiactl and nvidia0 from devfs. That
also obviously disables accelerated rendering on host unless the files are
remade.

I haven't seen this issue before in the past, and I've been wrestling
around with it for several weeks. I specifically waited until after the
latest Nvidia driver release, because I thought it may have been a strange
fault on Nvidia's part. I get a little hesitant to post to the mailing
list when I get an issue that I haven't seen reported anywhere yet, but
given how hard I've been trying to sort this out, I'm not even sure of any
other direction to try to get this working correctly.

I can't see anything about my configuration that would be affecting the way
Linux emulation works, let alone in such a strange way.

FreeBSD <snip> 7.0-PRERELEASE FreeBSD 7.0-PRERELEASE #17: Fri Oct 19
07:04:40 PDT 2007     <snip>:/usr/obj/usr/src/sys/<snip>  i386

CPU: AMD Athlon(tm) 64 Processor 3500+ (2188.81-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x20ff2  Stepping = 2
 
Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
  Features2=0x1<SSE3>
  AMD Features=0xe2500800<SYSCALL,NX,MMX+,FFXSR,LM,3DNow!+,3DNow!>
  AMD Features2=0x1<LAHF>
real memory  = 1609498624 (1534 MB)
avail memory = 1559240704 (1487 MB)

nvidia0: <GeForce 6800 XT> mem
0xfa000000-0xfaffffff,0xd0000000-0xdfffffff,0xfb000000-0xfbffffff irq 18
at device 0.0 on pci1
nvidia0: [GIANT-LOCKED]
nvidia0: [ITHREAD]

compat.linux.oss_version: 198144
compat.linux.osrelease: 2.6.16
compat.linux.osname: Linux

glxinfo: http://www.pastebin.ca/742439



More information about the freebsd-emulation mailing list