update archivers/rpm to 4.0.4?

Fernan Aguero fernan at iib.unsam.edu.ar
Wed Aug 18 12:49:47 PDT 2004


I need to install a linux application, and this application
needs python to be installed as a linux app, under
/compat/linux. I already installed all of the dependencies,
except for one (see below) by doing:

rpm --ignoreos --root /compat/linux --dbpath /var/lib/rpm \
--replacepkgs -i filename.rpm

The last dependency that I need to meet is the one producing
this message:
error: failed dependencies:
        rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by python-2.2.3-26

After searching around, it seems that this can be overcome
by updating rpm. However, here my confusion starts, because
rpm (3.0.6) and rpm4 are two different ports ... but they
install files with the same names.

My questions: 
i) would updating rpm to 4.0.4 serve to meet the python's dependency?
ii) may I safely remove rpm-3.0.6 and replace it with 4.0.4?

Adding to my confusion, I've found a rpm v4.1 under
/compar/linux/bin. However upon trying a command line
incantation similar to the one above 
(/compat/linux/bin/rpm --ignoreos ...) I get a long list of
failed dependencies including /bin/sh, /usr/bin/env, and
libc.so.6 and also the ones I already installed using the
rpm in /usr/local/bin. This list of failed dependencies does
not change if I change --dbpath
Do you know what's happening here?

Thanks in advance for any tip or pointer,


PS1: I'm running FreeBSD-4.10p2 with linux_base-8

PS2: please CC me since I'm not subscribed to this list

Fernan Aguero -  fernan at iib.unsam.edu.ar
Phone: +54 11 4580-7255/7 ext 310, Fax: +54 11 4752-9639
Check http://genoma.unsam.edu.ar/~fernan for more info.

More information about the freebsd-emulation mailing list