emulators/vmware2 vs. emulators/linux_base-8

Naoyuki Tai ntai at smartfruit.com
Tue Nov 11 13:27:21 PST 2003

Tim Pozar wrote:

> FYI...
> I was getting a number of panics for Vmare2 with the
> "emulators/linux_base-8" package.  Seems that folks may want to
> stay with the "emulators/linux_base" or "7" package.
> Tim
> _______________________________________________
> freebsd-emulation at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-emulation
> To unsubscribe, send any mail to "freebsd-emulation-unsubscribe at freebsd.org"

I have solved this problem with VMware3.
(Not VMware2)

After googling for a while, this is probably due to the
change in nice() in GNU C library.

You can fix the problem by either going back to old library
or patch the VMware binary to make it work with newer libc.

Here is what you can do. Download a patch.
There are many patches available. I used the latest in obsolete.
I do not know which one is which. But, this one worked for me.


Just google it and find it somewhere.

After downloading, untar in a directory.

Then, you have


in vmware-any-any-update42 directory.
update.c looks like it patches the file, and update is probably
compiled binary. So, I

cc -o ./foo update.c
./foo /usr/local/lib/vmware/bin/vmware

This patches the vmware binary.
At the moment, VMware is running on R4.9, am installing RH9.

Since update.c looks like it does patch vmware binary and
does not need to be linux binary, compiling update.c may be
universally possible for all paltforms.

Good luck.

Naoyuki "Tai" Tai, ntai a t smartfruit d o t com

More information about the freebsd-emulation mailing list