TP-WR1043: trying NFS root

Gleb Smirnoff glebius at
Mon Nov 28 08:20:50 UTC 2011

On Mon, Nov 28, 2011 at 12:13:36AM -0800, Oleksandr Tymoshenko wrote:
O> On 2011-11-27, at 11:32 PM, Gleb Smirnoff wrote:
O> > On Sun, Nov 27, 2011 at 11:18:10PM -0800, Oleksandr Tymoshenko wrote:
O> > O> > Stefan, Oleksandr,
O> > O> > 
O> > O> > which revisions have you tried? Revisions between r227791 and r227958 are already
O> > O> > known to have problems. Can you please clarify that you have tried revision r227958
O> > O> > or higher?
O> > O> 
O> > O> My source tree is r227960. I do not see "can't allocate llinfo" messages, just "in_scrubprefix: err=51, prefix delete failed"
O> > 
O> > Can you please obtain backtrace to determine which codepath causes error. Patch
O> > attached.
O> Sure, here it is:
O> in_scrubprefix+57c (?,?,?,?) ra 80435d28 sp a12980 sz 160
O> in_ifinit+38 (?,?,?,?) ra 80437328 sp a12a20 sz 96
O> in_control+bf8 (?,?,?,?) ra 8040ebb4 sp a12a80 sz 112
O> ifioctl+1974 (17ee000,?,?,?) ra 804add20 sp a12af0 sz 192
O> bootpc_init+1be0 (?,?,?,?) ra 802a642c sp a12bb0 sz 320
O> mi_startup+20c (?,?,?,?) ra 80100134 sp a12cf0 sz 32

Compiler have inlined bootpc_adjust_interface & bootpc_fakeup_interface into
bootpc_init so I can't determine which one is failing. Can you please
rebuild with:

make COPTFLAGS= DEBUG_FLAGS=-g buildkernel

Totus tuus, Glebius.

More information about the freebsd-embedded mailing list