eclipse-cdt debugging doesn't work on FreeBSD 7.0 amd64?

Mike Bowie mbowie at
Sun Nov 9 22:16:53 PST 2008

Mungyung Ryu wrote:
> Hello BSD guys,
> My system information is like this.
> - FreeBSD 7.0-RELEASE amd64
> - gcc 4.2.1
> - gdb 6.1.1
> - eclipse-cdt-3.1.2_1
> I used ports tree to compile and install eclipse-cdt-3.1.2_1.
> Running eclipse and compiling my C++ project are fine.
> But, when I try to debug, an error dialog box pops up and says 'Target
> selection failed'.
> The verbose console mode of the debugger option prints below.
==== snip ====
> I'm using PF for a firewall and opened TCP connection for port 10000 and
> I even disabled PF, but it has same error.
> There is anybody who've had and solved this kind of problem of eclipse?
> I'll really appreciate your solution.
> Going back to the command line gdb is quite miserable.
> I really wanna use eclipse for C++ debugging.
> Thanks.
> _______________________________________________
> freebsd-eclipse at mailing list
> To unsubscribe, send any mail to "freebsd-eclipse-unsubscribe at"

Hi Mungyung,

I seem to recall installing CDT from the update site in recent times; 
although I've not used it extensively, nor for debugging... might I 
suggest building a shiny new port from eclipse or eclipse-devel 
(Ganymede) and seeing if installing via the update manager yields a 
improved result?

My suggestion isn't really based on any kind of facts; simply an 
alternate approach.

Best of luck,


"You don't see FreeBSD developers sitting in a smoke-filled room 
plotting the overthrow of Microsoft. We sit in light, airy rooms and 
plot where to get the best drinks." - Michael Lucas

More information about the freebsd-eclipse mailing list