Eclipse 3.2.2 on 7.0-CURRENT

Garrett Cooper youshi10 at u.washington.edu
Sun Aug 26 17:26:13 PDT 2007


Greg Lewis wrote:
> On Sun, Aug 26, 2007 at 01:12:50PM -0700, Garrett Cooper wrote:
>   
>> Indigo 23 wrote:
>>     
>>> Anyone have Eclipse 3.2.2 running on 7.0-CURRENT, if so, did you have
>>> to do anything special?
>>>
>>> BTW, I'm using the latest diablo-jdk and jre.
>>>
>>> Thanks.
>>>       
>>    AFAIK diablo-jdk / -jre don't work on 7-CURRENT, because the FreeBSD 
>> foundation hasn't built a release yet for 7-CURRENT (because it's not a 
>> real release yet).
>>     
>
> It should work with the compat6x port.
>
> FYI, the fact that 7.x hasn't had a release yet pretty much rules out
> doing a binary for it.

    Threaded library stuff was broken in 7.x for Java until as of late 
(IIRC). You may want to inspect those threads in current@ to determine 
whether or not it's possible or ask on the list.
-Garrett


More information about the freebsd-eclipse mailing list