x220 notes

matt sendtomatt at gmail.com
Tue Mar 6 23:52:16 UTC 2012

On 03/06/12 15:25, Любомир Григоров wrote:
> I will be buying a X220 soon and have some questions:
> 1. Which wireless has better support?
> ThinkPad 11b/g/n Wireless (Realtek RTL8192SE / RTL8188CE)
> Intel Centrino Wireless-N 1000
> 2. I've read bad reviews about webcam having poor quality on
> GNU/Linux, so I would assume it will be the same on FreeBSD with
> webcamd and not worth the $30? (which also frees up space for 3x3 antenna)
> 3. Any disadvantages in usage for turning off the UEFI?
> 4. How far is the AMD64 kernel suspend/resume? What do you mean by
> video doesn't resume?
> 5. I'll be getting the IPS screen and want to make sure all the
> brightness issues won't f it up. Is there yet a working way to control
> brightness without interrupting the fan?
> Cheers.
> 2012/2/18 matt <sendtomatt at gmail.com <mailto:sendtomatt at gmail.com>>
>     I got 10-CURRENT installed on the x220 again.
>     1. Standard GENERIC kernel
>     2. Buildworld/installworld from today's CVS
>     3. No DRM/KMS patches or any other "factors"
>     4. Witness KDB disabled in loader.conf (otherwise panic on suspend).
>     5. setting hw.pci.do_power_suspend=0 wil prevent some AE_NO_METHOD
>     errors where it tries to set PCI express ports to D2 (the ports
>     themselves, I think...not the attached device)
>     This is what I've found as I investigate the backlight/resume issue. I
>     am not very good at understanding ASL, but here's what I see.
>     1. _WAK calls a number of display related methods
>     2. There are apparently brightness related calls here, as well as some
>     other video related calls
>     3. Some of this behavior depends on /VIGD, whatever that is.
>     4. The brightness calls seem to connect over LPC to the embedded
>     controller
>     5. Some of the brightness methods check OSI for WIN7
>     I will add that iasl finds 35 errors in this fine piece of lenovo
>     work.
>     However, none of the errors appear to be near _wak. I've attached an
>     acpidump asl if it helps anyone who has a better eye for ASL and
>     resume/brightness problems. I think we can control brightness at least
>     with acpi_video, it attaches but not correctly..."active=0"...I
>     haven't
>     gone back over its source in comparison with ASL yet either. Probably
>     acpi_ibm will work also, as the acpi methods seem to just call the
>     embedded controller over the lpc bus? Unfortunately it seems something
>     has changed with the ec, as some of the data becomes corrupt when
>     acpi_ibm is loaded.
>     Resume obviously works fine in Win7, works 80-95% of the time in Linux
>     (seems like KMS fail when it doesn't resume on Linux), and it resumes
>     fine on FreeBSD except no video. No bad messages in logs after resume.
>     Matt
>     _______________________________________________
>     freebsd-acpi at freebsd.org <mailto:freebsd-acpi at freebsd.org> mailing
>     list
>     http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
>     To unsubscribe, send any mail to
>     "freebsd-acpi-unsubscribe at freebsd.org
>     <mailto:freebsd-acpi-unsubscribe at freebsd.org>"
> -- 
> Lyubomir Grigorov (bgalakazam)
Ditch the webcam...it's grainy under linux, probably would be the same
under FreeBSD...haven't even tried.

Intel wireless is THE way to go...that Realtek is barely supported on
Linux (I believe 8192SU is still staging drivers...)

FreeBSD only legacy boots, however "UEFI USB Support" must be on to
allow USB booting for some reason.

I have IPS...it's very nice, but still no brightness yet. I'll get a
chance to look at again this weekend most likely. I think it's just an
issue with our acpi_ibm that isn't talking to the embedded controller right.

Resume works, but the screen is not on. I can now confirm it is *off*
and not just "dimmed/no backlight". Setting BIOS to use an external
monitor and disabling internal exhibits same behavior as internal
display, i.e external monitor set as BIOS primary does not come back
from power save. I have tried typing dpms force commands, did not work.

Once resume & brightness work, it will be great for FreeBSD...everything
else seemed fine, although I have not used fingerprint reader or card

An interesting note is that the BIOS does whitelist the wireless card,
and the wwan slot defaults to being a mSATA until it detects a
whitelisted USB ID or perhaps has no PCIe lines...not sure but my ral
card I'm working with will not detect in the second slot at all. The
slot may start as PCIe only in earlier bios, haven't checked (google
x220 egpu & x220 msata issue).


More information about the freebsd-current mailing list