killed somehow - help./ISO images of CURRENT

Dr. A. Haakh bugReporter at
Thu Feb 16 15:01:40 UTC 2012

O. Hartmann wrote:
> On 02/15/12 13:58, Dimitry Andric wrote:
>> On 2012-02-15 13:37, O. Hartmann wrote:
>>> ;-) Problem: I can not even login anymore, since I have "insecured" the
>>> console for security reasons and the shell is rejecting due to a symbol
>>> missing. I tried booting into single user mode, but that doesn't help
>>> much.
>> When booting in single user mode, use /rescue/sh as initial shell.  This
>> is statically linked, so should always be able to run.  Then use the
>> tools in /rescue to copy back a known good
> Last night I did and tried with no success.
> First I booted from a boot-only cd. After copying, I still
> received on binaries of the local disc
> Symbol "_ThreadRuneLocal" not found. So I copied all libs from cd to
> /lib/ on disc. That helped - for short. I tried to build world again
> with no success, since cc was missing on the boot/rescue  cd.
> So I booted the regular system again and tried building world. It
> failed, clang obviously suffered from the same missing symbol.
> The I did
> make clean cleandepend depend obj all install
> in folder
> /usr/src/lib.
> But after a reboot, I found myself confronted with the same initial
> situation when I started the thread.
> I guess I have "old" binaries and now too recent libs? I fear I'm
> missing one little specific point to repair the system.
> Regards,
> Oliver
If You have started the whole 'disaster' using 'make buildworld' then
all the necessary build-tools should still reside under /usr/obj/usr/src/tmp
or /usr/obj/usr/src/tmp/legacy including a statically linked clang. At least
this is the layout on 9.0-STABLE.

You can either setup your environment in single usermode to use these
(/usr/src/Makefile will give you some hints what to do) or copy them to
/usr/bin ...

Then try to rebuild and install your world (and kernel).

Hope this helps


More information about the freebsd-current mailing list