Can't umount a formerly mounted drive

Derek Tattersall dlt at
Fri Feb 3 18:50:57 UTC 2012

* Ryan Stone <rysto32 at> [120203 13:41]:
> On Fri, Feb 3, 2012 at 9:34 AM, Derek Tattersall <dlt at> wrote:
> > I have two drives in a x86-64 machine.  Drive ada2 has current on it, and
> > drive ada1 has 9-stable on it.  At some point, while running current, I
> > mounted the /home partition from stable to copy some files and re-ipled
> > the system into stable.  every thing worked properly.  Some time later I
> > ipled current again.  I then noticed that the stable /home was mounted
> > on /mnt.  I tried to umount it but the operation failed as /dev/ada1p7
> > was not considered mounted.  Yet with out mounting I could access all
> > the files on stable's /home, I could create and delete files.
> >
> > The current system was cvsup'ed on Wednesday this week, while the stable
> > system was cvsup'ed last Sunday.  Neither system has exhibited any
> > hiccups.  Can somebody explain what has happened her on the current
> > system and how it should be corrected?
> Does "mount" list anything as being mounted on /mnt?  If not, are you
> sure that /mnt isn't a symlink to somewhere else?  Or maybe the
> contents of the home directory were copied to /mnt by accident?
mount command on the current system does not list anything under /mnt.
ls /mnt on the current system list the top level directories on ada1p7,
the stable /home.  It lists them as soon as a user logs in on a newly
booted current system.  It's really frustrating.
Best regards,
Derek Tattersall
dlt at		dlt666 at		 dtatters at

More information about the freebsd-current mailing list