running old binaries on -current

Yamagi Burmeister lists at
Sun Dec 4 19:54:32 UTC 2011

On Fri, 2 Jul 2010 21:44:26 +0300
Kostik Belousov <kostikbel at> wrote:

> On Fri, Jul 02, 2010 at 11:12:13AM -0700, Julian Elischer wrote:
> > every now and then, for fun I run up a chroot of freebsd 1.1. or 1.0 
> > under a chroot.  Usually hillarity ensues with teh 15 second kernel 
> > compile and the 4 minute make world.
> > 
> > in -current I can't do that any more.. any binary just exits with 'Abort'.
> > 
> > I think I last tried it in 7.0 or there abouts.
> > 
> > I have options COMPAT_AOUT and COMPAT_FREEBSD4 through COMPAT_FREEBSD7
> > 
> > does anyone else have any ideas as to what may be needed?
> > 
> > I vaguely remember another option but I am not seeing it at the moment.
> > 
> > For those of you who do not remember, 1.0 had a.out static binaries only.
> > 
> Can you ktrace/kdump the run attempt, I suspect that abort is
> sent by image activator.
> Also, please put some static binary somewhere to download.

digging around I found one of the first programs ever written. It's an
static aout binary from 1994 or so, running it on FreeBSD 8.2 shows
exactly this problem. Some more extensive tests narrowed this problem
down to FreeBSD 1.x binaries, they're all broken. FreeBSD 2 aout
binaries are still working. 
Since Google found this rather old thread I decided to provide the data
your requested, but I do not insist on a fix. I guess that nobody will
try to run FreeBSD 1.x binaries these day... So if you want to spend
some work on this I'll test patches but if you decide to do nothing
it's okay.

This is the /bin/sh of FreeBSD 1.0 (taken from the official
installation cd image für i386):

% file sh
sh: VAX demand paged pure executable

% ./sh

The ktrace / kdump:
  1065 ktrace   RET   ktrace 0
  1065 ktrace   CALL  execve(0xbfbfee1b,0xbfbfecf8,0xbfbfed00)
  1065 ktrace   NAMI  "./sh"

I've uploaded the binary to:


XMPP:      yamagi at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list