So I tried a Firefox alpha in the Linuxolator... (unix domain socket patches)

Juergen Lock nox at
Sat Mar 27 20:18:29 UTC 2010

...hoping that the out of process plugin code would help the java
plugin hangs, but I only got flash working, java still is broken. :(
(Java does seem to work in linux-opera so it can't be the Linuxolator's
fault alone...)

 I did have to do some patches first tho because Firefox now uses
SO_PASSCRED on unix domain SOCK_SEQPACKET sockets, the first patch is
here, I've added some notes at the top that I'll quote:

 Looks like this part from dchagin's patch

didn't get applied, at least alpha versions of Linux Firefox 3.7 needs it

because of this code:

That Firefox also needs a small patch to allow setsockopt() with
SOCK_SEQPACKET, I've put that here:

..and if you aren't running head you also need to merge this commit first:

I'v put an 8-stable patch for that here:

(But the java plugin still doesn't work, only flash...)

 Oh and ff also attempts to use /proc/self/fd which is not yet in stable
and the epoll_create syscall which I think isn't even in head yet, but
it seems to have fallback code for those so they are not as important.


More information about the freebsd-current mailing list