vge traffic problem

David Ehrmann ehrmann at
Sun Jan 3 06:56:09 UTC 2010

I reported this problem before, but I have a specific, reproducible 
example, now.  I'm running 8.0 RC1.  I'm trying to fetch the source to 
upgrade to 8.0, but this happens:

# csup stable-supfile
Connected to
Receiver: Connection reset by peer
Will retry at 22:39:31

tcpdump output of that: (there seem to be a 
lot of duplicate acks being sent).

I tried with a different server, and I tried several times, but 
generally, the same thing, though I do occasionally get lucky.

I have a vr interface on my motherboard, so I gave it an IP address in a 
different subnet and changed the default gateway to a NAT box with the 
same default gateway as this box used to have (so I'm using the same 
internet connection).  Suddenly, it works.  Reproducibly.

I also have issues with samba, but putting that aside, netstat -s -p tcp 
reported this:

        289024537 packets received
                116305350 acks (for 1099476725 bytes)
                3119202 duplicate acks

That's a duplicate ack received for every 37 unique acks.  Seems pretty 
high for traffic on a small LAN, but I could be wrong.  I checked the 
cable; it is cat5e or cat 6.  I also tried plugging the vge port into a 
10/100 mbps switch, but csup still failed.

Ideas?  I saw that there were a few recent changes to vge, but I'm not 
sure if they're related to this.

More information about the freebsd-current mailing list