ums fails to initialise correctly

Hans Petter Selasky hselasky at
Mon Feb 22 16:14:10 UTC 2010

On Monday 22 February 2010 14:41:18 Chris Hedley wrote:
> I wasn't sure whether this question was better asked on this list or the
> freebsd-usb one; but since I'm already subscribed here, I figured it was a
> good place to start.
> I'm having a lot of problems getting the ums (USB mouse) driver to
> initialise the mouse correctly.  The only time it'll do so is if I
> physically unplug the mouse and reattach it; otherwise, it seems there's
> no way of getting it to initialise correctly.  The mouse in question is a
> Logitech MX Revolution wireless model, though I'm not sure how relevant
> that is.
> Confusingly, the kernel messages are identical when it comes to seeing the
> mouse initially and reattaching it; perhaps significantly, if I plug it
> into my KVM switch (as opposed to one of the computer's own ports), it
> still fails to initialise if I switch it away from the FreeBSD system and
> back again: I have to do the physical detach/reattach process to get it to
> reinitialise.  One possible lead is that once the mouse is working, it's
> fine when it's switched between the two FreeBSD systems, but switching to
> Windows and back renders it unusable again until I physically reattach it.
> I had wondered if it might be some hardware weirdness, but Windows (XP and
> 7) and Linux (on the same computer as FreeBSD) have no problems with it.
> The symptoms are just a lack of any data; otherwise everything seems
> identical between it working and not: the messages are the same, the /dev
> entry is being created correctly, devd starts up the moused process for
> me, but there's nothing.  It's not a moused problem either, cat -v
> /dev/ums1 also reveals no data.
> I've tried pretty much every BIOS configuration I can think of, I've tried
> FreeBSD with both the ehci and ohci drivers, both compiled into the kernel
> and as modules; I've used usbconfig to see if there's any difference in
> configuration between the mouse working and not working, but nothing at
> all; variously loading and unloading ums, attempting to reset it or do a
> software power off and back on with usbconfig also won't bring it back to
> life.  Meanwhile, the USB keyboard "just works", whatever I do.
> I spent much of the past couple of days Googling for suggestions and
> discovered it wasn't an uncommon problem, but could find no definite
> solution (other than suggestions to disable legacy support if it was
> enabled and vice versa - which didn't work).  I did find similar queries
> going back to 2003, which makes me wonder if it's a problem without any
> obvious solution, but I thought I'd ask anyway.
> I'm using -current in its amd64 form on an old-ish dual-core AMD with an
> Asus motherboard, if that gives anybody any clues.  But I figure I should
> get back to whether or not this is the right place to ask before I start
> posting reams of configuration and debugging information!


What is printed to dmesg when you enable debugging?

sysctl hw.usb.ums.debug=15


More information about the freebsd-current mailing list