USB 1.1 devs not working on ASUS K8VSE (x86) MB

Tom Uffner tom at
Thu Dec 9 16:46:01 UTC 2010

I have a fairly recent Current system running on an ASUS K8V SE Deluxe MB.

It was a dual boot amd64/x86 system (until a few days ago when the drive
w/ the amd64 partitions unexpectedly failed after only a week of use)

When running it as x86, USB 1.1 devices are not recognized by FreeBSD.
They worked fine on the amd64 kernel built from the same code. both
ohci and uhci are in the kernel even though they don't show up in dmesg.
the devices in question (currently a 1.1 hub and a mouse) are both seen
and activated by the BIOS but turned off once FreeBSD takes over.

I had the same problem with GENERIC kernels from the 9.0-current-201011
snapshot, so it is not my kernel config.

the mouse also works fine on either x86 or amd64 when plugged into a
USB 2.0 hub or a PS2 adapter. and both these devices worked w/ the x86
kernel on the previous incarnation of this system with an ASUS A7N8X MB
(NVIDIA chipset) so i suspect that the problem may be in the initialization
code for the Via chipset.

thanks in advance for any help,

FreeBSD 9.0-CURRENT FreeBSD 9.0-CURRENT #292: Wed Dec  8 
13:10:15 EST 2010     root@:/usr/obj/usr/src/sys/XIOMBARG  i386

Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.0-CURRENT #292: Wed Dec  8 13:10:15 EST 2010
     root@:/usr/obj/usr/src/sys/XIOMBARG i386
CPU: AMD Athlon(tm) 64 Processor 3200+ (2202.87-MHz 686-class CPU)
   Origin = "AuthenticAMD"  Id = 0xfc0  Family = f  Model = c  Stepping = 0
   AMD Features=0xe0500800<SYSCALL,NX,MMX+,LM,3DNow!+,3DNow!>
real memory  = 2147483648 (2048 MB)
avail memory = 2094309376 (1997 MB)
Event timer "LAPIC" quality 400
ioapic0: Changing APIC ID to 1
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 0.3> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <A M I OEMRSDT> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 7fef0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8385 host to PCI bridge> on hostb0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xa000-0xa0ff mem 
0xe0000000-0xefffffff,0xfce00000-0xfce0ffff irq 16 at device 0.0 on pci1
vgapci1: <VGA-compatible display> mem 
0xd0000000-0xdfffffff,0xfcc00000-0xfcc0ffff at device 0.1 on pci1
atapci0: <Promise PDC20771 SATA300 controller> port 
0xe800-0xe87f,0xe400-0xe4ff mem 0xfda00000-0xfda00fff,0xfd900000-0xfd91ffff 
irq 16 at device 9.0 on pci0
ata2: <ATA channel 0> on atapci0
ata3: <ATA channel 1> on atapci0
ata4: <ATA channel 2> on atapci0
skc0: <Marvell Gigabit Ethernet> port 0xe000-0xe0ff mem 0xfdc00000-0xfdc03fff 
irq 17 at device 10.0 on pci0
skc0: Marvell Yukon Lite Gigabit Ethernet rev. A3(0x7)
sk0: <Marvell Semiconductor, Inc. Yukon> on skc0
sk0: Ethernet address: 00:11:2f:38:7b:87
miibus0: <MII bus> on sk0
e1000phy0: <Marvell 88E1011 Gigabit PHY> PHY 0 on miibus0
e1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 
1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto
re0: <RealTek 8169/8169S/8169SB(L)/8110S/8110SB(L) Gigabit Ethernet> port 
0xd800-0xd8ff mem 0xfd700000-0xfd7000ff irq 17 at device 12.0 on pci0
re0: Chip rev. 0x10000000
re0: MAC rev. 0x00000000
miibus1: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus1
rgephy0:  10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 
100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 
1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, 
re0: Ethernet address: 00:14:d1:14:33:e6
pcm0: <CMedia CMI8738> port 0xd400-0xd4ff irq 19 at device 14.0 on pci0
atapci1: <VIA 6420 SATA150 controller> port 
irq 20 at device 15.0 on pci0
ata5: <ATA channel 0> on atapci1
ata6: <ATA channel 1> on atapci1
atapci2: <VIA 8237 UDMA133 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfc00-0xfc0f at device 15.1 on pci0
ata0: <ATA channel 0> on atapci2
ata1: <ATA channel 1> on atapci2
pci0: <serial bus, USB> at device 16.0 (no driver attached)
pci0: <serial bus, USB> at device 16.1 (no driver attached)
pci0: <serial bus, USB> at device 16.2 (no driver attached)
pci0: <serial bus, USB> at device 16.3 (no driver attached)
ehci0: <VIA VT6202 USB 2.0 controller> mem 0xfd500000-0xfd5000ff irq 21 at 
device 16.4 on pci0
usbus0: EHCI version 1.0
usbus0: <VIA VT6202 USB 2.0 controller> on ehci0
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xcd000-0xd57ff pnpid ORM0000 
on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: parallel port not found.
powernow0: <Cool`n'Quiet K8> on cpu0
Timecounter "TSC" frequency 2202867030 Hz quality 800
Timecounters tick every 1.000 msec
ata2: SIGNATURE: 00000101
usbus0: 480Mbps High Speed USB v2.0
ugen0.1: <VIA> at usbus0
uhub0: <VIA EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0
ada0 at ata2 bus 0 scbus0 target 0 lun 0cd0 at ata0 bus 0 scbus5 target 0 lun 0
cd0: <LITE-ON DVDRW SOHW-1693S KS06> Removable CD-ROM SCSI-0 device
cd0: 66.700MB/s transfers (UDMA4, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present
cd1 at ata1 bus 0 scbus6 target 0 lun 0
cd1: <HL-DT-ST RW/DVD GCC-4320B 1.01> Removable CD-ROM SCSI-0 device
cd1: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
cd1: Attempt to query device size failed: NOT READY, Medium not present

ada0: <WDC WD10EACS-00D6B1 01.01A01> ATA-8 SATA 2.x device
ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada0: 953869MB (1953525168 512 byte sectors: 16H 63S/T 16383C)
GEOM: ada0s1: geometry does not match label (255h,63s != 16h,63s).
Root mount waiting for: usbus0
Root mount waiting for: usbus0
uhub0: 8 ports with 8 removable, self powered
Root mount waiting for: usbus0
Root mount waiting for: usbus0
uhub_reattach_port: port 4 reset failed, error=USB_ERR_TIMEOUT
uhub_reattach_port: device problem (USB_ERR_TIMEOUT), disabling port 4
Trying to mount root from ufs:/dev/ada0s1a [rw]...
uhub_reattach_port: port 5 reset failed, error=USB_ERR_TIMEOUT
uhub_reattach_port: device problem (USB_ERR_TIMEOUT), disabling port 5
drm0: <ATI Radeon AP 9600> on vgapci0
vgapci0: child drm0 requested pci_enable_busmaster
info: [drm] AGP at 0xf8000000 32MB
info: [drm] Initialized radeon 1.31.0 20080613
info: [drm] Setting GART location based on new memory map
info: [drm] Loading R300 Microcode
info: [drm] Num pipes: 1
info: [drm] writeback test succeeded in 1 usecs
info: [drm] Num pipes: 1

More information about the freebsd-current mailing list