Can't boot 8.0-BETA4 from USB stick

Scott Long scottl at
Mon Sep 14 07:34:18 UTC 2009

On Sep 13, 2009, at 9:32 PM, James Butler wrote:
> 2009/9/11 Randi Harper <randi at>:
>> On Thu, Sep 10, 2009 at 3:22 PM, James Butler <sweetnavelorange at 
>> >
>> wrote:
>>> 2009/9/11 Randi Harper <randi at>:
>>>> On Thu, Sep 10, 2009 at 2:48 PM, James Butler
>>>> <sweetnavelorange at>
>>>> wrote:
>>>>> 2009/9/10 Hans Petter Selasky <hselasky at>:
>>>>>> On Thursday 10 September 2009 06:37:13 James Butler wrote:
>>>>>>> Is there anything else worth trying?
>>>>>> Another brand of memory sticks?
>>>>> I have only the three different brands that I tried (Toshiba and  
>>>>> two
>>>>> different no-names). Is there really nothing like an adjustable  
>>>>> delay
>>>>> at boot? Perhaps it's time to spend NZD$30 on a CF card and IDE
>>>>> adapter, but that will be of limited use for troubleshooting or
>>>>> installation.
>>>>> -James
>>>>> _______________________________________________
>>>>> freebsd-current at mailing list
>>>>> To unsubscribe, send any mail to
>>>>> "freebsd-current-unsubscribe at"
>>>> I've been asking around about an option to delay before mounting  
>>>> root as
>>>> well. I don't know of anything off the top of my head, but it  
>>>> sounds to
>>>> me
>>>> like a bug (or at least a reasonable feature request). Send a PR?
>>> I probably will now, I just wanted to exhaust the existing  
>>> options. It
>>> seems to me that a "wait for the configured root device to appear"
>>> timeout could be arbitrarily long (eg. 10+ secs) by default without
>>> adversely affecting the normal use case, but I don't claim to know  
>>> how
>>> the boot process works.
>>>> Have you only tried this on the one computer? It seems suspicious  
>>>> that
>>>> all
>>>> the cards are having this problem when I've only heard of two  
>>>> cases of
>>>> USB
>>>> flash-slowness causing problems so far. I'm curious to see if you  
>>>> have
>>>> the
>>>> same problem using that flash disk with a different computer.
>>> I think I used the same drive to test-install 8.0-BETA1 on my old
>>> Thinkpad X31, which seemed to work OK. This Asus motherboard is a  
>>> but
>>> useless in other ways; still, 7.2 runs fine.
>>> -James
>>> _______________________________________________
>>> freebsd-current at mailing list
>>> To unsubscribe, send any mail to "freebsd-current-unsubscribe at 
>>> "
>> To avoid adversely affecting the normal use case, a tunable could  
>> specify
>> the option of having the mount wait until the device appears, or  
>> possibly
>> for how long to delay the mount. This really isn't my area of  
>> expertise,
>> though, so take what I say with a grain of salt.
>> Not sure if you've seen these, but this is a problem other people are
>> reporting as well:
>> Relevant but not enlightening:
>> Slightly more helpful:
>> Not all that relevant, but interesting anyways:
> Ha - I didn't find anything when I searched the lists, must've been
> what my wife calls a "boy look".
> FYI:

Delaying the mountroot doesn't fix the problem.  The problem is that  
there's a race between the process doing the USB tree discovery, and  
the process doing the CAM/SCSI bus scan.  The tree discovery needs to  
happen before the bus scan, and no amount of root delay tweaks will  
help that, except maybe accidentally by shifting timings.  I'm working  
on the correct solution.  I'll hopefully have something tomorrow.


More information about the freebsd-current mailing list