[HEADSUP] amd64 suspend/resume code to be comitted

Daniel Thiele dthiele at gmx.net
Wed Mar 25 17:05:47 PDT 2009

Jung-uk Kim wrote:
> On Wednesday 25 March 2009 05:28 pm, Gustau Perez wrote:
>>> Please try the attached patch, which just disables restoring VGA
>>> state while resuming.
>>   Tried your patch again, and this time using hw.acpi.reset_video,
>> hw.acpi.suspend_bounce and friends. The same result, the screen
>> remains completely black.
>>    Before appliying the patch, when resuming the screen showed
>> messages about the resume of some hardware (usb, firewire, etc ...)
>> and then it went black.
>>   Is there anything I can test ?
> Then, it is something else, e.g., acpi_video(4).  You can try setting 
> debug.acpi.disabled="video" in /boot/loader.conf for example.

I have the same problem here with a ThinkPad T400. This is a model with
the Switchable Graphics feature, but I set the corresponding BIOS option
to use the integrated Intel GMA X4500 only. Suspend and resume seem to
work except for video output. I am using a vanilla CURRENT from March 25
(so I have not tried the vga_isa.diff patch yet).

As in Gustau's case, after resume the screen stays just black. The
system, though, seems to be up and running, since I get console's
audible bell when I expect it and I can edit files, blindly of course.
Setting debug.acpi.disabled="video" in /boot/loader.conf produces the
same result: A black screen right after resume.

I also tried setting hw.acpi.reset_video to 1 but the the machine does
not resume at all. When I, in this case, additionally turn on
debug.acpi.resume_beep all I get is a long beep that only stops, if I
power-cycle the machine.

Also, at first I tried to use an USB flash drive to test suspend/resume
on amd64, which results in a panic on suspend. Unfortunately, I don't
have any dumps, but the "tracing pid" output from "where" at the
debugger prompt reported PID 12, wich seems to be [intr]. Or at leas it
seem to be intr whenever I look up PID 12. Right now I am (ab)using my
swap partition, which works fine.

So, if there are any other knobs to fiddle with or patches to try out
to investigate this further (at least the black screen issue) just let
me know.

Best regards,


More information about the freebsd-current mailing list