CFT: ee 1.5.0

Ed Schouten ed at
Tue Jun 9 18:26:31 UTC 2009

Hi Gabor, Adam,

* Gabor Kovesdan <gabor at> wrote:
> Adam McDougall escribió:
>> After using the new ee in a -current build, it seems like an old issue
>> has come back where if the containing xterm is resized, ee ungracefully
>> exits without saving.  I think it was fixed a while ago but a quick look
>> at the modern ee.c seems to indicate this was lost:

The resize issue: i tried to fix it properly, but the issue is that the
fix that we had was not accurate. It could cause ee to keep spinning
infinitely. I tried to fix it, but it turned out wgetch() doesn't really
do what the manpage states:

| Programmers concerned about portability should be prepared  for  either
| of  two  cases: (a) signal receipt does not interrupt getch; (b) signal
| receipt interrupts getch and causes it to return ERR with errno set  to
| EINTR.   Under the ncurses implementation, handled signals never inter-
| rupt getch.

It turns out ncurses just returns with errno set to 0, very weird.

> There's another regression. If you edit more files with one command line  
> (ee foo bar baz ...) and modify one of them and just look into the rest  
> each file will be treated as modified and you will be asked if you want  
> to save it. This wasn't the case before the upgrade.

Editing multiple files: it probably has to do something with
text_changes not being set to FALSE properly.

I'll see if I can find some time to look at these issues within the next
couple of days. Hang in there! ;-)

 Ed Schouten <ed at>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list