KDE4/DBUS weirdness on -Current

Paul Wootton paul at fletchermoorland.co.uk
Thu Jan 29 05:35:40 PST 2009

>On Monday 26 January 2009 14:29:21 Pegasus Mc Cleaft wrote:
>> Hello Current,
>> >
>>     First I appologize for not having much debug information, as I havent
>> been able to pinpoint an exact cause yet, but I noticed something odd with
>> -Current 25012009. After updating all my ports while running on a
>> 23012009-Current and rebooting, everything seemed to work fine; however,
>> after updating usr/src from about 11pm on 25012009, KDE started to act
>> really strange.
>>     After poking around with various things, I discovered that the dbus
>> daemon stopped responding. This manifisted its self by clicking on icons
>> and having the window manager lock up for about 1 minute. After which, a
>> message came back that the dbus daemon could not be contacted. I tried
>> dbus-monitor, but got exactly the same message. I tried both USB1 and USB2
>> stacks, just to make sure, but could never get things to copperate. I did
>> find, right after logging in through KDM, I could get a single application
>> to launch (So DBUS had to been ok at this point) but after about 5 seconds,
>> DBUS would stop responding)
>>     I reverted my kernel to the version before the upgrade (kernel.old) and
>> everything started to work fine again (I am running on the more recent
>> world and the old kernel).
>>     I am not really sure how to find the exact failure here, but I can
>> duplicate the fault by loading the 25th's kernel.
>>     Machine is a Core2-quad running on AMD64, 8 Gig, USB1 or USB2 stack.
>>     Does anyone have any insight to what this might be? (Or how I might be
>> able to diagnose further)
>> ~Peg
>> _______________________________________________
>> freebsd-current at freebsd.org mailing list
>> http://lists.freebsd.org/mailman/listinfo/freebsd-current
>> To unsubscribe, send any mail to "freebsd-current-unsubscribe at freebsd.org"

>On Monday 26 January 2009 15:09:45 Alberto Villa wrote:
> On Mon, Jan 26, 2009 at 2:29 PM, Pegasus Mc Cleaft <ken at mthelicon.com> 
> >    Does anyone have any insight to what this might be? (Or how I might be
> > able to diagnose further)
> that's not a new problem, but your information might help
> try mailing at kde-freebsd at freebsd.org

Hi All,

I have just csup-ed my src tree from 13/01 to 28/01 and am now seeing the same 
problem as Peg. 

If this is as Alberto said "not a new problem" and indeed a KDE issue, then 
why have I not seen this before, and it has only just happened after a new 
kernel and world.

I managed to launch xterm and then konqueror from the shell.
Knoqueror eventually loads after about 2 minutes and gives a title of "Error: 
Cannot initiate the http Protocol"  and the page displays
"The requested operation could not be completed
Cannot Initiate the http Protocol
Technical Reason: Unable to Launch Process
Details of the Request:
URL: http://*********************
Protocol: http
Date and Time: Thursday 29 January 2009 12:26
Additional Information: Cannot talk to klauncher: Did not receive a reply. 
Possible causes include: the remote application did not send a reply, the 
message bus security policy blocked the reply, the reply timeout expired, or 
the network connection was broken.
The program on your computer which provides access to the http protocol could 
not be started. This is usually due to technical reasons."

However, I can run dbus-monitor and there are messages flowing through

If I revert back to the old kernel but still use the new world the problem 
seems to go away

Have anyone else seen this issue?


More information about the freebsd-current mailing list