FreeBSD panics with 64GiB of RAM

Attila Nagy bra at
Thu Jan 22 05:31:52 PST 2009

Gavin Atkinson wrote:
> On Sat, 17 Jan 2009, Attila Nagy wrote:
>> Hello,
>> I've already tried something similar. The effect of the patch is this:
>> BTW, this:
>> boots up fine (to sysinstall).
>> I haven't installed FreeBSD for years (I'm using netboot), is this i386?
>> That could explain the situation.
> I'm confused.  That link is a snapshot of amd64 -CURRENT from 
> December. The first email in this thread said you were trying -CURRENT 
> anmd64 and it wasn't working.
> So, which ones work and which don't?  Are we looking at a regression 
> since December or has this been fixed between whatever image you first 
> tested and the December snapshot?
The screenshots were made with an up to date (at that point of course) 
But I've tried to boot with the snapshot ISO, which boots fine.

- the original problem: with a fresh pxeloader, the machine halts at 
this point:
- 8-CURRENT, booting with an older pxeloader panics with this:
- the 640kB patch panics with this (8-CURRENT, older pxeloader):
- with safe mode, I get this (8-CURRENT, older pxeloader, apparently no 
NICs recognized):
- the December snapshot ISO with CD-ROM redirection boots fine, and it 
seems the SMAP is OK too:

According to these, I think my problem is the pxeloader's inability to 
boot on this machine. An older one can't boot because of the 
memory-related difference, a newer one can not boot because of another 
changes, happening in-between.

Somebody please help. :)

I don't know if there is a version, which can get to the loader prompt 
AND initialize what need to be initialized correctly to overcome the 

More information about the freebsd-current mailing list