mouse problems

Brooks Davis brooks at one-eyed-alien.net
Fri Nov 19 10:28:51 PST 2004


On Fri, Nov 19, 2004 at 01:14:52PM -0500, Chuck Robey wrote:
> On Fri, 19 Nov 2004, Chuck Robey wrote:
> 
> > > The PS/2 mouse is configured in /etc/rc.conf with the lines:
> > >
> > > moused_enable="YES"
> > > moused_flags=""
> > >
> > > and the USB mouse is handled by the default entrly in usbd.conf which is
> > > enabled in rc.conf with:
> > >
> > > usbd_enable="YES"
> >
> > VERY good, thanks for the response, please work with me here.  First, I'm
> > working with a brand new amd64 install, so my etc is hopefully (and more
> > properly, my rc.conf) up to date, it has a mouse_ports, but not a
> > moused_flags at all, so you may be working witha customized etc ... no big
> > surprise.  I interpolated, tried your settings, on reboot I have no
> > /dev/psm0 device.  I looked at the psm man page, and I dolled up the
> > /boot/loader.conf as instructed.  on reboot, kenv reports what I would
> > want to see, but still no /dev/psm0 (which is why, I suppose, I have only
> > a single moused process running, the usbd.conf inspired one.  That one,
> > the mouse cursor still disappears the moment I touch the keyboard..
> >
> > That info I did, I tried both with and without the atkbdc hint in the mail
> > archives.
> >
> > I notice, btw, that the usb (ums0) gets probed by the kernel well, well
> > before rc.conf gets asked about psm0 ... I bet that timing is something
> > that, if I could change, might help things.  I would like the psm to get
> > started before the usb one.
> 
> Bad etiquete to reply to myself, but I had more ideas, and I tried them.
> I'm again at an end, but I have this to add: I went in and deleted the
> ums0 entry from usbd.conf, so that it won't get attached; if I use the
> serial converter so that my keyboard and mouse are serial, then /dev/psm0
> does get created; if ums0 is being cteaed first, then /dev/psm0 is
> unavailble to the system for some reason, I can't get it created later on.
> I need some method to delay the usb processing for the keyboard and mouse
> combo UNTIL all of the PS/2 processing is finished.
> 
> Obviously, /dev/psm0 and /dev/ums0 get along poorly.
> 
> BTW, yes, I tried adding the ums0 back after I had the good (?)
> /dev/psm0, again, the mouse cursor disappears the moment I touch the
> keyboard.  It flickers to life, and is immediately gone.  I don't
> understand abou that, your notion about running two moused processes was
> aluring.
> 
> Funny point?  for the PS/2 case, rc.conf is NOT making a moused process.
> That's not working.  OK, that's something I can investigate.
> 
> Again, if anyone thinks they know all of the steps to completely delete
> the ps/2 mouse an dkeyboard from the system (leaving me the usb ones) let
> me know, I'll try anything that looks like a complete task list.

Does your BIOS have a legacy mode setting?  If so, please try disabling
it.

-- Brooks

-- 
Any statement of the form "X is the one, true Y" is FALSE.
PGP fingerprint 655D 519C 26A7 82E7 2529  9BF0 5D8E 8BE9 F238 1AD4
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20041119/5d3aa563/attachment.bin


More information about the freebsd-current mailing list