world breakage in pam_echo

Doug White dwhite at gumbysoft.com
Wed Jul 16 12:27:27 PDT 2003


On Wed, 16 Jul 2003, Christian Brueffer wrote:

> my world is broken with the following error message for some days now:
>
>
> ===> lib/libpam/modules/pam_echo
> cc -O2 -pipe -march=pentium2 -I/usr/src/lib/libpam/modules/pam_echo/../../../../contrib/openpam/include -I/usr/src/lib/libpam/modules/pam_echo/../../libpam  -Wsystem-headers -Werror -Wall -Wno-format-y2k -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wcast-align -Wno-uninitialized  -c /usr/src/lib/libpam/modules/pam_echo/pam_echo.c

1.  Optimization levels above -O are not supported.
2.  -Werror is NOT recommended post-gcc 3.3 upgrade unless you are fixing
    warnings.  gcc3.3 is much more warn-happy.  I'm not sure how you got
    -Werror in there since it was removed prior to the gcc3.3 import.

-- 
Doug White                    |  FreeBSD: The Power to Serve
dwhite at gumbysoft.com          |  www.FreeBSD.org


More information about the freebsd-current mailing list