portupgrade system destruction? SOLVED

Eric Anderson anderson at centtech.com
Wed Jan 5 02:33:34 GMT 2005

Kris Kennaway wrote:
>>>>I have a few dedicated servers at a hosting company (about 3 hours drive 
>>>>time away).  On one of the systems I ran a 'portupgrade -arR' this 
>>>>morning, and then disconnected (I ran it in a screen session). About an 
>>>>hour later, I realized I could not log in anymore via ssh.  Seems that I 
>>>>can connect, but my passwords fail (permission denied).  I can't FTP in, 
>>>>or check mail with any username/password combos.  Even my preshared SSH 
>>>>keys do not work.  When connecting via POP, I get this message:
>>>>Connected to hostname.
>>>>Escape character is '^]'.
>>>>/usr/libexec/ld-elf.so.1: Shared object "libc-client4.so.8" not found
>>>>Connection closed by foreign host.
>>>>Can anyone help me figure out what may have gone wrong?
>>>Probably you're 1) using an ssh port instead of the base system
>>>version, and 2) the portupgrade stalled or exited somewhere in between
>>>updating a library it depends on and updating the port itself (ditto
>>>for pop).  System upgrades can be dangerous when you don't have a
>>>fallback plan :-)
>>Is ssh a port by default in 4.10?  I thought it was in the base os.. How 
>>would that explain my ftp access problems too?  Seems like they would 
>>not be tied..
> No.  Something unexpected has clearly happened..maybe your system ran
> out of swap space?

For those that are curious - what happened was the night before, I 
installed a new port, but needed to change $PREFIX to a user's home area 
to set the port up in that particular spot.  As expected, that went 
uneventfully. The next morning,  I decided to do a portupgrade - and 
promptly went about cvsupping my ports, bla bla, and then doing a 
portupgrage -arR.  However - I never unset the $PREFIX variable, so each 
port was being removed from the main system area, then the new port was 
being installed in a users' home area.  Bash was one of the first to be 
done, which explains the login errors (/usr/local/bin/bash was removed 
from /etc/shells, and it was replaced with 
/home/username/usr/local....bash, so my shell in the passwd file no 
longer was in /etc/shells file).  The portupgrade continued until some 
point when it basically killed itself off.

I'm now recovering pieces of the installed packages.



Eric Anderson        Sr. Systems Administrator        Centaur Technology
When in doubt, mumble; when in trouble, delegate; when in charge, ponder

More information about the freebsd-chat mailing list