portupgrade system destruction?

Eric Anderson anderson at centtech.com
Tue Jan 4 04:27:35 GMT 2005

Kris Kennaway wrote:
> On Mon, Jan 03, 2005 at 09:17:12PM -0600, Eric Anderson wrote:
>>I have a few dedicated servers at a hosting company (about 3 hours drive 
>>time away).  On one of the systems I ran a 'portupgrade -arR' this 
>>morning, and then disconnected (I ran it in a screen session). About an 
>>hour later, I realized I could not log in anymore via ssh.  Seems that I 
>>can connect, but my passwords fail (permission denied).  I can't FTP in, 
>>or check mail with any username/password combos.  Even my preshared SSH 
>>keys do not work.  When connecting via POP, I get this message:
>>Connected to hostname.
>>Escape character is '^]'.
>>/usr/libexec/ld-elf.so.1: Shared object "libc-client4.so.8" not found
>>Connection closed by foreign host.
>>Can anyone help me figure out what may have gone wrong?
> Probably you're 1) using an ssh port instead of the base system
> version, and 2) the portupgrade stalled or exited somewhere in between
> updating a library it depends on and updating the port itself (ditto
> for pop).  System upgrades can be dangerous when you don't have a
> fallback plan :-)

Is ssh a port by default in 4.10?  I thought it was in the base os.. How 
would that explain my ftp access problems too?  Seems like they would 
not be tied..

>>or walk someone through a fix?
> Depends on exactly what has gone wrong.  You'll need to at least get
> someone to tell you what's on the console, if anything.
> In future, consider setting up a serial console from another machine
> that you can access remotely.  You can repair almost anything this way
> without needing physical access to the machine (since you can reboot
> and do stuff from single-user mode).

Unfortunately, I didn't get to build it, and I can get any physical 
access to it - it's in a rack somewhere.  If I had the opportunity to do 
that, I would have before now. :)

Just seems odd that a portupgrade could smash the system so badly.

Any ideas on what 'libc-client4.so.8' is installed from?  Maybe that 
would help me find the culprit port.

Thanks for the thoughts..

Eric Anderson        Sr. Systems Administrator        Centaur Technology
When in doubt, mumble; when in trouble, delegate; when in charge, ponder

More information about the freebsd-chat mailing list